[opus] opusfile 0.4 release

Timothy B. Terriberry tterribe at xiph.org
Wed Aug 21 23:59:41 PDT 2013

Ralph Giles wrote:
> In addition to what Tim said, do you get the same error loading
> libopusfile-0.dll, or is it just libopusurl? Could it be an ordering
> problem?

For those playing along at home:

libopusfile-0.dll _did_ work, but libopusurl-0.dll did not. The reason 
was that alpha thinktank was explicitly loading libopusfile-0.dll's 
dependencies (libogg-0.dll and libopus-0.dll) so that he could use 
GetProcAddress() to pull entry points out of them, but he was _not_ 
loading libopusurl-0.dll's OpenSSL dependencies libeay32.dll and 
ssleay32.dll. Manually loading those before libopusurl-0.dll solved the 
problem for me. It's possible there are other solutions involving 
LoadLibraryEx flags to modify the search path, but this is the only one 
I tested.

So, I'm not sure there's much we can do in the construction of the DLLs 
themselves to fix this. I think it has to be addressed in the calling 
application. If someone knows another way, feel free to chime in.

More information about the opus mailing list