[CELT-dev] Celtenc not working in 0.9.1

Maurizio Locatelli maurizio at locatelli.be
Sun Dec 19 14:53:53 PST 2010


I'm currently testing libcelt (celt-0.9.1) on my Openwrt/Kamikaze 
RDC-3210 platform and although I'm able to Crosscompile on my Ubuntu 
10.10 machine without errors, the resulting celtenc doesn't seem to work 

Ran ./configure via the Openwrt makefile first (activating fixed-point) ;

I first produce a S16_LE Raw PCM file (48Khz, stereo) : test.pcm

Then I try to encode it using this commandline :
celtenc --cbr --rate 48000 --bitrate 48 --stereo --comp 5
  test.pcm test.oga

The encoder just writes a 173-byte header into the *.oga file with 
following output at stderr:
Encoding 48 kHz stereo audio in 20ms packets at 48.000kbit/sec (120 
bytes per packet, CBR) with bitstream version -2147483662

Further investigation reveals a bizarre return-value for 'bitstream 
value' from celt_mode_info, instead of 2000 (from #define), it gives a 
negative value ;

Thinking it would be some weird compiler or porting issue between 
regular C and the OpenWrt platform (the machine is a 
RDC3210-SOC-processor), I tried to compile the sources on the Ubuntu-box.

Same result here. Something weird is going on.

The test-tools run fine on the Ubuntu-box (all except the tandem-test);

I don't know if I should post this issue on the Openwrt forum or here.

I'm open for suggestions. I can post more info if needed.

More information about the celt-dev mailing list