[CELT-dev] FIXED_POINT

Elston Sa jose at rebaca.com
Wed Sep 16 03:52:13 PDT 2009


Yes indeed. I was missing DOUBLE_PRECISION and MIXED_PRECISION defines. 

Many thanks,

Elston

-----Original Message-----
From: Jean-Marc Valin [mailto:Jean-Marc.Valin at USherbrooke.ca] 
Sent: Tuesday, September 15, 2009 7:23 PM
To: Gregory Maxwell
Cc: Elston Sa; celt-dev at xiph.org
Subject: Re: [CELT-dev] FIXED_POINT

Note that for fixed-point to work, you need to define the following:

#define FIXED_POINT
#define DOUBLE_PRECISION
#define MIXED_PRECISION

otherwise you'll get strange results.

   Jean-Marc

Quoting Gregory Maxwell <gmaxwell at gmail.com>:

> On Tue, Sep 15, 2009 at 5:12 AM, Elston Sa <jose at rebaca.com> wrote:
> > I have build celt with FIXED_POINT option (latest 0.6.1 as well as from
the
> > git repo) on windows. However I am not getting a valid output (all
samples
> > are saturated) when I try to decode with this version.  The input file
was
> > encoded with the same fixed point version. Does fixed point version work
at
> > all?
>
> Yes, fixed point it tested in parallel with floating point. Since you
> say you're building on windows, is it possible that you haven't setup
> the correct defines for fixed point mode? Or is this a cygwin build
> configured through autotools?
>
> > Following are the command line settings;
> > Samplerate; 48000
> > Channels: 2
> > Framesize: 256
> > Bytesperpacket: 1024
> > Complexity: 10
>
> You're asking CELT for 1.536Mbit/sec output, it's also possible that
> you're triggering a fixed-point specific bug. I don't to regular
> testing at rates that high.  Does it work at more typical rates such
> as 128 bytes per packet?
> _______________________________________________
> celt-dev mailing list
> celt-dev at xiph.org
> http://lists.xiph.org/mailman/listinfo/celt-dev
>







More information about the celt-dev mailing list