[ogg-dev] [PATCH] browser_plugin - kate support, build fixes, and misc

Conrad Parker conrad at metadecks.org
Wed Apr 30 02:29:37 PDT 2008

2008/4/30 ogg.k.ogg.k at googlemail.com <ogg.k.ogg.k at googlemail.com>:
> > > Let me know if this works for you or not; eg. it may be necessary to
>  > > also put X_EXTRA_LIBS etc. in src/Makefile.am.
>  >
>  > will try this.
>  It worked fine for me, with no need to add anything to Makefile.am.


>  > > >   - bad pointer dereference fix (mouse callback)
>  > >
>  > > I couldn't find that particular hunk, could you please provide a patch
>  > > which just fixes this?
>  >
>  > Two hunks, the first one to initialize the mouse callback pointer
>  > to NULL, and the second one to test for NULL before actually using it:
>  That didn't compile though, sorry, the attached patch fixes that. I edited
>  the original patch by hand to remove the Kate stuff and it seems I ended
>  up with a stray comma.

sorry, that was my fault with the merge; I fixed it a few hours later in r3576

>  Also, I'd entirely forgotten about that, but I need to set FIREFOX_CFLAGS
>  and FIREFOX_LIBS to (resp) "-I$(ffpath)/include" and "-L$(ffpath)/lib" for
>  configure to not whine it can't find Firefox. I've got the Gecko SDK, but
>  I can't see any pc files in there, so the configure.ac check's got me
>  puzzled. Since it all builds and run if I do that, I can only guess that
>  the reason is that I'm using a prebuilt version (I did hear that FF is a
>  real pain to build, and my dev box is still having FF 1 :)). I've got:
>  gecko-sdk-i686-pc-linux-gnu-
>  If you decide you don't want to support building against prebuilt SDKs,
>  then that's fine by me, just wanted to mention it.

hmm, perhaps we should add some configure arguments like
--with-firefox-cflags= and --with-firefox-libs=

>  Next, the audio code doesn't build for me, same thing about old software.
>  My /usr/include/alsa/version.h says "1.0.9". Various functions are being
>  undefined. I can supply the list if needed, but you may want to decide to
>  not support old versions.
>  Last, the building of the static lib fails, as it tries to pull liboggz,
>  liboggplay, etc, out of /usr/local/lib (well, @LIBDIR@) rather than from
>  wherever pkg-config says they are.

ok, what architecture are you on? that's been reported on x86_64 but
may occur elsewhere

>  I'd omitted these chunks from my previous patch (esp. the ALSA one, which
>  is down to my own peculiar configuration), but that last one (which I do
>  not know how to fix) is likely to be annoying, as I suppose a distribution
>  of the plugin as a binary is going to include the static one, rather than
>  the shared one (just guessing here).
>  If you know how to fix it, feel free to tell me if there's a patch you
>  want me to test here.

will do, but we don't have a patch for that yet :-)



More information about the ogg-dev mailing list