<html>
  <head>
    <meta content="text/html; charset=ISO-8859-1"
      http-equiv="Content-Type">
  </head>
  <body bgcolor="#FFFFFF" text="#000000">
    <div class="moz-cite-prefix">On 05/25/2014 01:13 PM, Jordan Verner
      wrote:<br>
    </div>
    <blockquote cite="mid:COL130-W291E33E56BC1AF72443F7DE2380@phx.gbl"
      type="cite">
      <style><!--
.hmmessage P
{
margin:0px;
padding:0px
}
body.hmmessage
{
font-size: 12pt;
font-family:Calibri
}
--></style>
      <div dir="ltr">Icecast and Ices are running on the same machine
        and it is a dedicated server.<br>
        It is a Xeon 1270 V2 CPU with 16 GB ram running Centos 64-bit.<br>
        Any thoughts on which settings I could try next? I have tried
        everything that appears to relate to the speed at which the
        stream occurs to no avail.<br>
        One point I forgot to mention is that some tracks bring on more
        deviation than others. Shorter tracks, like spots, through it
        off more than longer tracks (I think). There are definitely
        tracks that inflict this effect more than others.<br>
      </div>
    </blockquote>
    <br>
    I'm going to revise my guess. It's probably inaccuracies in how you
    account for track length in your system. But ultimately it's
    irrelevant.<br>
    I'd suggest to explore the idea of a filler jingle, as pointed out
    earlier. If you want to get fancy, you can even have several to
    dynamically chose to adjust for the offset more accurately.
    Although, I'm going to say that this is overkill and a 10s
    jingle/sound file should be just fine, also most listener software
    will have a buffer of 10-60s anyway, so being "on the dot" doesn't
    really come out right anyway. If you want silence, then please note
    that you should use very low level noise instead of digital silence.
    For the listener it will be indistinguishable, as the noise will
    probably be below the noise floor of their sound card, but for the
    vorbis encoder this makes a crucial difference. Digital silence
    compresses down to single bits per second and will lead to source
    timeouts and ill effects in listener software and should be avoided
    at all cost when streaming.<br>
    <br>
    <br>
    <blockquote cite="mid:COL130-W291E33E56BC1AF72443F7DE2380@phx.gbl"
      type="cite">
      <div dir="ltr">I haven't&nbsp;experienced any other timing oddities on
        the machine.<br>
      </div>
    </blockquote>
    <br>
    If you can live with the above, then I'd suggest to take that route.<br>
    <br>
    Cheers<br>
    <br>
    TBR<br>
    <br>
    <br>
    <blockquote cite="mid:COL130-W291E33E56BC1AF72443F7DE2380@phx.gbl"
      type="cite">
      <div dir="ltr">&nbsp;<br>
        <div>&gt; Date: Sun, 25 May 2014 07:05:42 +0000<br>
          &gt; From: <a class="moz-txt-link-abbreviated" href="mailto:thomas@ruecker.fi">thomas@ruecker.fi</a><br>
          &gt; To: <a class="moz-txt-link-abbreviated" href="mailto:icecast@xiph.org">icecast@xiph.org</a><br>
          &gt; Subject: Re: [Icecast] Keeping icecast + ices 2.X running
          on a strict schedule?<br>
          &gt; <br>
          &gt; Hi,<br>
          &gt; <br>
          &gt; On 05/24/2014 11:29 PM, Jordan Verner wrote:<br>
          &gt; &gt; I'm using Icecast, Ices, and the script module
          configuration to serve<br>
          &gt; &gt; the playlist to the server. Playlists are scheduled
          once per day with<br>
          &gt; &gt; regularely placed events (like spots) which run at
          specific times.<br>
          &gt; &gt; Unfortunately it's being served too fast, so it's
          always getting ahead<br>
          &gt; &gt; of schedule (gaining about 10 seconds on every
          hour).<br>
          &gt; <br>
          &gt; Sounds like the clocking is faster for some reason.<br>
          &gt; <br>
          &gt; &gt; I have tried adjusting the flush-samples setting in
          ices.xml and the<br>
          &gt; &gt; queue size in the icecast.xml file to no avail.<br>
          &gt; &gt; I've had to resort to implementing a forced delay
          into the php script<br>
          &gt; &gt; which feeds the filenames to ices, so that if ices
          calls it<br>
          &gt; &gt; significantly early it'll wait to issue the next
          filename until it's<br>
          &gt; &gt; closer to it's scheduled start time. This was
          causing disconnects<br>
          &gt; &gt; whenever it became deviated beyond 10 seconds.
          Disabling source<br>
          &gt; &gt; timeout fixed this, but still it tries to get as far
          ahead as<br>
          &gt; &gt; physically possible and takes as much wiggle room as
          I give it plus more.<br>
          &gt; <br>
          &gt; That won't fix it. You're inserting gaps into the stream
          and that's a<br>
          &gt; bad thing for your listeners too.<br>
          &gt; <br>
          &gt; &gt; Is there any fix for this? Streaming for 24 hours
          would have it<br>
          &gt; &gt; calling the script as much as 4 minutes ahead of
          schedule, forcing my<br>
          &gt; &gt; script to hang for all that time before issuing each
          and every filename.<br>
          &gt; &gt; This is way too much deviation for streams which
          stick to a schedule.<br>
          &gt; &gt; Two weeks of streaming would have everything an hour
          early.<br>
          &gt; <br>
          &gt; So for some reason on your system Ices is running 0.28%
          faster. I'm not<br>
          &gt; sure what causes this and where those samples go. Is it
          by chance a<br>
          &gt; virtual machine?<br>
          &gt; <br>
          &gt; You can try to fiddle further with ices settings. If that
          doesn't fix it<br>
          &gt; then you could always have your script insert a 10s
          filler jingle if it<br>
          &gt; detects that you're out of the timeframe.<br>
          &gt; <br>
          &gt; Other options would be to explore different automation
          solutions, but<br>
          &gt; they might suffer the same problem if it's some
          underlying clock oddity<br>
          &gt; on your system.<br>
          &gt; <br>
          &gt; Cheers<br>
          &gt; <br>
          &gt; Thomas<br>
          &gt; _______________________________________________<br>
          &gt; Icecast mailing list<br>
          &gt; <a class="moz-txt-link-abbreviated" href="mailto:Icecast@xiph.org">Icecast@xiph.org</a><br>
          &gt; <a class="moz-txt-link-freetext" href="http://lists.xiph.org/mailman/listinfo/icecast">http://lists.xiph.org/mailman/listinfo/icecast</a><br>
        </div>
      </div>
      <br>
      <fieldset class="mimeAttachmentHeader"></fieldset>
      <br>
      <pre wrap="">_______________________________________________
Icecast mailing list
<a class="moz-txt-link-abbreviated" href="mailto:Icecast@xiph.org">Icecast@xiph.org</a>
<a class="moz-txt-link-freetext" href="http://lists.xiph.org/mailman/listinfo/icecast">http://lists.xiph.org/mailman/listinfo/icecast</a>
</pre>
    </blockquote>
    <br>
  </body>
</html>