[Icecast] proper ssl setup question

tyctor tyctor at post.cz
Thu Jan 14 14:51:22 UTC 2021


that's it, on 8000 stream still working
only 8001 is stopped

but good if this is proper setup
problem could be elsewhere
icecast is running inside container
i will try to change this 8001 to other number to see if this will also
happen

thanks for reply

On Thu, 2021-01-14 at 15:25 +0100, Wang wrote:
> That should be the right way to do it, yes.
> I did it this way and it worked. :-)
> 
> Perhaps the reason why the streaming stops is not because
> of the server setup, but because of ezstream.
> Does the stream also stop on port 8000?
> 
> tyctor <tyctor at post.cz> schrieb am 14.01.2021 14:10:
> > hi 
> > 
> > i have question about ssl setup
> > in icecast.xml we have defined two ports
> > (8000 without ssl and 8001 with ssl)
> > 
> > <listen-socket>
> >    <port>8000</port>
> > </listen-socket>
> > <listen-socket>
> >    <port>8001</port>
> >    <ssl>1</ssl>
> > </listen-socket>
> > 
> > on backend side there is ezstream which streams mp3 recordings to
> > port
> > 8000 (without ssl)
> > 
> > we are using port 8001 (with ssl) from our website, where audio
> > player
> > use it as src
> > it is because our site is running on https only, so every link and
> > src
> > need to go via ssl
> > 
> > we are using icecast builded with ssl from repository 
> > http://download.opensuse.org/repositories/multimedia:/xiph/xUbuntu_18.04/
> > 
> > is this proper way how should be ssl configured and used on
> > icecast?
> > i am asking because once in a while icecast stop streaming on port
> > 8001
> > and need to be restarted to continue
> > 
> > thanks for any hints
> > tyctor
> _______________________________________________
> Icecast mailing list
> Icecast at xiph.org
> http://lists.xiph.org/mailman/listinfo/icecast



More information about the Icecast mailing list