[Icecast] Streaming SSL / HTTPS with m3u file

Damian db76 at riseup.net
Sat Jul 18 09:30:28 UTC 2020


Hi,

I installed icecast2 on Debian 10 via backports for buster so that I could get ssl support.
I’ve successfully configured iceacst to stream via ssl within the browser. No problems there. 
For instance I can successfully open a https link to the stream with a URL like https://domain-name.net:8433/mountname <https://domain-name.net:8433/mountname>

However, the same URL with .m3u at the end fails

The issue seems to be similar to this thread ... https://gitlab.xiph.org/xiph/icecast-server/-/issues/2323 <https://gitlab.xiph.org/xiph/icecast-server/-/issues/2323>

When trying to open m3u or xspf stream links via the icecast status.xsl page, it gives errors. Hovering over the m3u or xspf stream links shows a https URL, but when opening the file in a client, it tries to play a http stream and fails. The actual contents of the file shows a http link to the stream rather than a https link. Seems to be something internal to icecast.

The icecast.xsl config is set up for ssl as follows:

   <hostname>IP address or domain HERE</hostname>

    <!-- You may have multiple <listen-socket> elements-->
    <listen-socket>
        <port>8000</port>
        <bind-address>127.0.0.1</bind-address>
        <!-- <shoutcast-mount>/stream</shoutcast-mount> -->
    </listen-socket>

    <listen-socket>
        <port>8443</port>
        <ssl>1</ssl>
    </listen-socket>


Can you confirm whether the issue in the thread above has been resolved? … and is there something else I need to do in the config to avert this problem?

Cheers

Damian
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.xiph.org/pipermail/icecast/attachments/20200718/81446f71/attachment.html>


More information about the Icecast mailing list