[Icecast] Icecast streaming https

Henk van de Ridder henk.vande.ridder at solcon.nl
Wed Feb 5 17:53:24 UTC 2020

I am struggling to get icecast running with https, but I cannot get it working

My environment is: Debian 10 (Buster)


I tried the standard debian package but there is no SSL capability at all.


So I compiled the icecast-2.4.4.tar.gz contents with ./configure --with-curl --with-openssl; make; make install


I always get the error: [2020-02-05  17:35:36] INFO connection/get_ssl_certificate No SSL capability on any configured ports


The parts of the icecast.xml are:














The letsencrypt.pem is combined out of the certificate (cert.key) and private key file.

The letsencrypt.pem is readeable for the icecast user

I allready tried other pem’s but nothing solves the problem.


(Just for reference I already have https running on debian 7 (wheezy) with the icecast-kh-icecast-2.4.0-kh7 version.


Does anyone realised met the same problem with a solution for this ? 

Have you some advices for me ?


Many thanks in advice


Henk van de Ridder



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.xiph.org/pipermail/icecast/attachments/20200205/f5d20db7/attachment.htm>

More information about the Icecast mailing list