[Icecast] Icecast 2.4.3 stop play on https

Michel van Dop mvandop at xs4all.nl
Wed Sep 5 08:00:06 UTC 2018


Hi,

For information, the stream play for 5 months from April. After the
restart, the problem was solved for 2.4.3 and https works fine.

Have someone see this problem? 
We use Icecast 2.4.0 CentOS 7 64bit. And every 10 or 15 hours Icecast
crash. In the system log we see:

kernel: icecast[3244]: segfault at 7fe66037e000 ip 00007fe66aeaf4cb sp
00007fe6670ac9d8 error 4 in libc-2.17.so[7fe66ad5a000+1c3000]

We stream on FLAC and opus. When we set FLAC on a bigger bitrate, The
Icecast application crash faster.
(glibc-2.17-222.el7.x86_64)

Best regards,
Michel

> Hi,
> 
> We use Icecast 2.4.3 and SSL streaming for a long time on CentOS 6 and 7.
> The last time we have some problems on playing 192k mp3 on https. 
> The stream play 2 second and stop, on http we have not that problem. (we restart the encoder, but same problem)
> (we use a jPlayer and direct stream url in chrome)
> 
> We check on the error log, but no errors and in the access log we see:
> 2001:980:79b3:0:b1cd:e5ab:3280:e9bd - - [03/Sep/2018:17:24:00 +0200] "GET /live HTTP/1.1" 200 11648 "https://www.domein.nl/" "Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/68.0.3440.106 Safari/537.36" 2
> 
> Its not a IPv6 problem we have this problem on IPv4.
> 
> Best regards,
> Michel
> 
> _______________________________________________
> Icecast mailing list
> Icecast at xiph.org
> http://lists.xiph.org/mailman/listinfo/icecast

--
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.xiph.org/pipermail/icecast/attachments/20180905/1170dafb/attachment.html>


More information about the Icecast mailing list