[Icecast] [PATCH] Don't use deprecated API with openssl 1.1+

Eneas U de Queiroz cote2004-github at yahoo.com
Tue May 29 12:34:10 UTC 2018


OpenSSL 1.1.0 has deprecated SSL_load_error_strings and
SSL_library_init.  Initialization is done automatically, so they're not
needed with icecast.  Fixes issue #2318

Signed-off-by: Eneas U de Queiroz <cote2004-github at yahoo.com>
---
 src/tls.c | 2 ++
 1 file changed, 2 insertions(+)

diff --git a/src/tls.c b/src/tls.c
index 36edd86..6bd1aee 100644
--- a/src/tls.c
+++ b/src/tls.c
@@ -51,8 +51,10 @@ struct tls_tag {
 
 void       tls_initialize(void)
 {
+#if OPENSSL_VERSION_NUMBER < 0x10100000L
     SSL_load_error_strings(); /* readable error messages */
     SSL_library_init(); /* initialize library */
+#endif
 }
 void       tls_shutdown(void)
 {
-- 
2.16.1



More information about the Icecast mailing list