[Icecast] SSL.

Olivier BATARD obatard at hammicus.org
Sun Oct 9 20:58:50 UTC 2016


Hello,

I’m new to icecast and I’m trying to setup icecast on Debian 8, with the 2.4.3 version, compiled manually.


The thing is I can’t make the ssl part work.

I have a listen directive like this :

<listen-socket>
        <port>8483</port>
        <ssl>1</ssl>
 </listen-socket>

and ssl-certificate : 

<ssl-certificate>/usr/local/share/icecast/icecast.pem</ssl-certificate>

I generated the certificate with the commands :

openssl req -x509 -newkey rsa:4096 -keyout key.pem -out cert.pem -nodes -days 365
cat key.pem >> crt.pem

But when I start the server, everything is fine but I can’t load the page https://server.domain.local:8483/admin <https://server.domain.local:8483/admin>

The browser hangs and close the connection with an error : « can’t establish a secure connection » 

Here’s the icecast logs :

[2016-10-09  20:55:02] INFO stats/_stats_thread stats thread started
[2016-10-09  20:55:02] INFO yp/yp_update_thread YP update thread started
[2016-10-09  20:56:30] INFO sighandler/_sig_die Caught signal 2, shutting down...
[2016-10-09  20:56:30] INFO main/main Shutting down
[2016-10-09  20:56:30] INFO fserve/fserve_shutdown file serving stopped
[2016-10-09  20:56:31] INFO slave/_slave_thread shutting down current relays
[2016-10-09  20:56:31] INFO slave/_slave_thread Slave thread shutdown complete
[2016-10-09  20:56:31] INFO auth/auth_shutdown Auth shutdown
[2016-10-09  20:56:31] INFO yp/yp_shutdown YP thread down
[2016-10-09  20:56:31] INFO stats/stats_shutdown stats thread finished

I don’t understand what I missed.

Can anyone help me ?

Thanks by advance,

Olivier.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.xiph.org/pipermail/icecast/attachments/20161009/90d3d0ea/attachment.html>


More information about the Icecast mailing list