[Icecast] Icecast URL authentication problem

Klaas Jan Wierenga k.j.wierenga at gmail.com
Fri Jun 5 01:19:04 PDT 2015


Hi,

If you're running icecast in a jail root (chroot enabled), then you may not have a properly setup DNS resolver.

Maybe this post will point you in the right direction: http://icecast.xiph.narkive.com/5v2EeNBD/eror-no-dns <http://icecast.xiph.narkive.com/5v2EeNBD/eror-no-dns>

Kind regards,
KJ


> Op 3 jun. 2015, om 22:34 heeft infoweb1 at crobiz.com het volgende geschreven:
> 
> System: Icecast 2.4.1 and 2.4.2, OS: CentOS 6.6 x64
>  
> Tried to install icecast using following two different methods described in these links:
> (1) http://www.ukhost4u.co.uk/blog/538/install-icecast-2-centos-6-server/ <http://www.ukhost4u.co.uk/blog/538/install-icecast-2-centos-6-server/>
> (2) https://www.servint.net/university/article/taking-the-chill-out-of-installing-icecast/ <https://www.servint.net/university/article/taking-the-chill-out-of-installing-icecast/>
>  
>  
> Both of these resulted in working and stable icecast, but without the possibility of url authentication.
>  
>  
> Mountpoint authentication is configured as shown here:
> <authentication type="url">
> <option name="mount_add"       value="http://some.server.org/stream_control.php"/ <http://some.server.org/stream_control.php%22/>>
> <option name="mount_remove"    value="http://some.server.org/stream_control.php"/ <http://some.server.org/stream_control.php%22/>>
> <option name="listener_add"    value="http://some.server.org/stream_control.php"/ <http://some.server.org/stream_control.php%22/>>
> <option name="listener_remove" value="http://some.server.org/stream_control.php"/ <http://some.server.org/stream_control.php%22/>>
> <option name="stream_auth" value="http://some.server.org/stream_control.php"/ <http://some.server.org/stream_control.php%22/>>
> <option name="user" value='source'/>
> <option name="pass" value='pass'/>
> <option name="auth_header" value="icecast-auth-user: 1"/>
> </authentication>
>  
> Script named stream_control.php just writes POST data received from calling site (to some file) and returns icecast-auth-user: 1.
>  
>  
> This script is never called by any of these methods by the icecast server, also in the error.log I am able to find following lines (every time I try to connect to icecast as a listener - or a stream client):
>  
> INFO auth/auth_add_listener adding client for authentication
> INFO auth/queue_auth_client auth on /mountpoint has 1 pending
> INFO auth_url/url_add_listener client auth (http://some.server.org/stream_control.php) <http://some.server.org/stream_control.php)> failed with ""
>  
>  
>  
> Please advise further actions. Thanks!
>  
>  
> PS: yum update was done, without any change.
> _______________________________________________
> Icecast mailing list
> Icecast at xiph.org
> http://lists.xiph.org/mailman/listinfo/icecast

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.xiph.org/pipermail/icecast/attachments/20150605/3d4413c6/attachment.htm 


More information about the Icecast mailing list