[Icecast] upgrading icecast to 2.4.1

"Thomas B. Rücker" thomas at ruecker.fi
Wed Feb 25 12:45:38 PST 2015


On 02/25/2015 08:08 PM, Jonathan wrote:
> Done that and all works... Thanks. and I could still use my old config 
> file with all of my settings in it? Because that is what I'm still using 
> now.

Yes, we're ensuring backwards compatibility with mainline Icecast releases.

If you are planning to use the JSON API directly from browsers, you
should add the headers though.

    <http-headers>
        <header name="Access-Control-Allow-Origin" value="*" />
    </http-headers>

For the rest I'd recommend release notes of all versions in between and
documentation.
http://icecast.org/docs/icecast-2.4.1/config-file.html


Cheers

Thomas


>
> On 2/25/2015 12:22 PM, "Thomas B. Rücker" wrote:
>> On 02/25/2015 07:17 PM, Jonathan wrote:
>>> I will send you the errors first and then the modified script.
>>>
>>> Adding official Icecast repository for Ubuntu 14.04
>>> add-icecast-repo: line 4: $'\r': command not found
>>> Importing GPG key for official Icecast repository
>>> "pg: Invalid option "-
>>> add-icecast-repo: line 7: $'\r': command not found
>>> Now, here is my script that I have changed
>> Was Windows somehow involved in obtaining or transferring the script?
>> Try running "dos2unix add-icecast-repo" and then retry running the script.
>>
>>
>>> #!/bin/sh
>>> echo Adding official Icecast repository for Ubuntu 14.04
>>> sudo sh -c "echo deb
>>> http://download.opensuse.org/repositories/home:/dm8tbr/xUbuntu_14.04/ ./
>>>   >>/etc/apt/sources.list.d/icecast.list"
>>>
>>> echo Importing GPG key for official Icecast repository
>>> wget -qO -
>>> http://download.opensuse.org/repositories/home:/dm8tbr/xUbuntu_14.04/Release.key
>>> | sudo apt-key add -
>> I guess that looks fine (slightly mangled by Thunderbird).
>>
>>
>> Cheers
>>
>> Thomas
>>> On 2/25/2015 12:00 PM, "Thomas B. Rücker" wrote:
>>>> On 02/25/2015 06:40 PM, Jonathan wrote:
>>>>> Just wondering, are the commands to upgrade icecast 2.3.2 to icecast
>>>>> version 2.4.1 the same in Ubuntu 12.04 as they are in Ubuntu 14.04? I
>>>>> do have Ubuntu 14.04 and I have tried the bash script but modified the
>>>>> links a little bit to reflect the Ubuntu 14.04 distro, but keep
>>>>> getting errors and got an invalid extension in /etc/apt/sources.list.d
>>>> Did you use the commands from the previously attached script?
>>>> The inline commands were malformed.
>>>>
>>>> The repository URL for 14.04 is:
>>>> http://download.opensuse.org/repositories/home:/dm8tbr/xUbuntu_14.04/
>>>>
>>>> I actually tested the script (with the 14.04 URL) on my 14.04 machine
>>>> before I originally sent it, so after fixing the URL it should have worked.
>>>>
>>>> What error messages are you getting?
>>>>
>>>>
>>>> Cheers
>>>>
>>>> Thomas
>>>>
>>>> PS: Seeing, that there is demand for this, I'm going to see to get this
>>>> information added to the download page of icecast.org
>>>>




More information about the Icecast mailing list