[Icecast] can't use icecast2 in ubuntu 12.04

Simone Dal Maso simone.dalmaso at gmail.com
Thu Jul 31 02:10:15 PDT 2014


Hello!
I solved the problem, probably in a terrible manner.
but one thing is absolutely clear, the problem was the firewall.
I decided simply to delete all sort of rules, reading a little tutorial 
on the net. I  simply issued the following commands:

iptables -F
iptables -X
iptables -t nat -F
iptables -t nat -X
iptables -t mangle -F
iptables -t mangle -X
iptables -P INPUT ACCEPT
iptables -P FORWARD ACCEPT
iptables -P OUTPUT ACCEPT

Now, icecast works absolutely well!
I really hope to be able to restore some basic rules of my firewall, 
because I am not a good unix user, so I know ufw, the is the 
uncomplicated firewall, but nothing about iptables.
anyway, a complete deletion of all rules solved.
I really want to thank you because you point my attention to the 
firewall and connection issues!
thank you thank you thank you!


Thomas B. Rücker (il 31/07/2014 10:50) ha scritto:
> On 07/31/2014 08:38 AM, Simone Dal Maso wrote:
>> Thomas B. Rücker (il 30/07/2014 23:26) ha scritto:
>>    You could run "tcpdump -ni eth0 port 8000" and try to access the
>>> icecast web interface. If you don't see any output, then traffic to port
>>> 8000 is blocked externally.
>> good point of view.
>> Ok, let's try:
>>    root at mail2:/home/spaziouser# tcpdump -ni eth0 port 8000
> <snip />
>>    8 packets captured
> <snap />
>> so I think that connectivity exist. the same result is with icecast2
>> disabled.
>
> yeah, looks good.
> One down, let's look further.
>
>
>> I think that for some strange reason firewall or something is blocking
>> icecast2 for listening.
>> really strange!
>
> Let's continue with the basics then:
> - start Icecast
> - "netstat -altpn | grep 8000"
> - "iptables-save"
>
> please post the output.
>
> Let's see if that gets us any closer to solving this.
>
> Cheers
>
> Thomas
> _______________________________________________
> Icecast mailing list
> Icecast at xiph.org
> http://lists.xiph.org/mailman/listinfo/icecast
>



More information about the Icecast mailing list