[Icecast] No sound on any stream.

Brad nyctelecomm at gmail.com
Thu Jan 24 13:47:43 PST 2013


I figured out half the issue.

Icecast appears to be transmitting on port 8000 just fine. The more I dig,
the more I realize icecast is fine.

Browser vlc seems to be broke. Direct connect via VLC standalone to ->
http://66.228.49.182:8000/66.228.49.182.ogg.m3u  works perfect. 

http://tinypic.com/r/2yl1qhc/6

 

I break there.

Thank you!

 

Brad

 

From: Don Soad [mailto:s04d.1982 at gmail.com] 
Sent: Thursday, January 24, 2013 4:20 PM
To: Brad
Cc: icecast at xiph.org
Subject: Re: [Icecast] No sound on any stream.

 

Have you tried mpd or ices2 as the actual music player? Do you experience
the same issues?

Jose

El ene 24, 2013 12:34 PM, "Brad" <nyctelecomm at gmail.com> escribió:

I have 2 icecast servers and neither will play music, 1 gentoo, the other
ubuntu when connect to a mount and trying to broadcast via mixxx using both
mp3 or ogg. Both will establish a stream feed but appears to have no sound.
One of them won't even stream a ices2 mounted song either (same symptom,
connect but no actual play occurs). Error logs are clean too, firewall is
turned off on both client and server, one server is a virtualbox image ontop
of the desktop I am trying to stream to.
Multiple computers have been tested from every possible direction.

 

<icecast>

    <limits>

        <clients>100</clients>

        <sources>2</sources>

        <threadpool>5</threadpool>

        <queue-size>524288</queue-size>

        <client-timeout>30</client-timeout>

        <header-timeout>15</header-timeout>

        <source-timeout>10</source-timeout>

        <burst-on-connect>1</burst-on-connect>

        <burst-size>65535</burst-size>

    </limits>

    <authentication>

        <source-password>blah</source-password>

        <!-- Relays log in username 'relay' -->

        <relay-password>blah</relay-password>

        <admin-user>admin</admin-user>

        <admin-password>blah</admin-password>

    </authentication>

    <hostname>66.228.49.182</hostname>

    <listen-socket>

        <port>8000</port>

    </listen-socket>

    <mount>

        <mount-name>/66.228.49.182.ogg</mount-name>

        <username>source</username>

        <password>blah</password>

    </mount>

    <Playlist>

        <File>/etc/ices2/playlist.txt</File>

        <Randomize>1</Randomize>

        <Type>builtin</Type>

        <Module>mpd</Module>

        <Crossfade>0</Crossfade>

    </Playlist>

    <fileserve>1</fileserve>

    <shoutcast-mount>/live.nsv</shoutcast-mount>

    <paths>

        <basedir>/usr/share/icecast</basedir>

        <logdir>/var/log/icecast</logdir>

        <webroot>/usr/share/icecast/web</webroot>

        <adminroot>/usr/share/icecast/admin</adminroot>

        <alias source="/" dest="/status.xsl"/>

    </paths>

    <logging>

        <accesslog>access.log</accesslog>

        <errorlog>error.log</errorlog>

        <loglevel>4</loglevel> <!-- 4 Debug, 3 Info, 2 Warn, 1 Error -->

        <logsize>10000</logsize>

        <!-- <logarchive>1</logarchive> -->

    </logging>

    <security>

        <chroot>0</chroot>

        <changeowner>

            <user>icecast</user>

            <group>nogroup</group>

        </changeowner>

    </security>

</icecast>

 

 

Brad


_______________________________________________
Icecast mailing list
Icecast at xiph.org
http://lists.xiph.org/mailman/listinfo/icecast

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.xiph.org/pipermail/icecast/attachments/20130124/011b8b77/attachment-0001.htm 


More information about the Icecast mailing list