[Icecast] disconnected mount point listed in the status page

Rücker Thomas thomas.ruecker at tieto.com
Sat Jan 19 04:13:31 PST 2013


Hi,

On 18/01/13 07:53, Alexandru Matei wrote:
> Hi!
>
> This days I switched from icecast 2.3.2 to the latest icecast kh from 
> the github (build 30-gfe06a77). But the problem I'm speaking about 
> didn't solve.
>
> After a source disconnects the mount point remains listed in the 
> status page with only these entries:
>
>
>       Mount Point /stream
>
> 	M3U <http://ortodoxradio.ro:8000/stream.m3u>XSPF 
> <http://ortodoxradio.ro:8000/stream.xspf>
>
> Current Listeners: 	0
> Current Song:
>
>

It is known behaviour especially if there are fallbacks or other 
specific options involved that empty and not connected mounts will be 
listed.
There may of course be a bug somewhere in there, but most of it seems to 
be working-as-intended.

> This happens when the source is the old oddcast and also when the 
> source is liquidsoap. Sometimes this doesn't happen at all.
>
> In the admin/list mountpoints it's listed. And if I want to kill the 
> source from the admin home page I used to get an error (now in the kh 
> version - a black page appears).
>

Now that sounds different. So you're saying that even though there is no 
source client connected and has not been for at least as long as the 
source time-out you have configured, that an active mount is still shown?

If so, then I'd need more details about your setup, e.g. a copy of the 
icecast.xml (with passwords redacted). Access logs and error logs at 
DBUG level.
Also it would be important to know if this happens with Icecast 2.3.3 
(latest official) or at latest svn trunk. A report based on KH-branch 
doesn't help me as it has a quite divergent code-base.

Cheers

Thomas


More information about the Icecast mailing list