[Icecast] Alert Email

Phil - w2lie w2lie at w2lie.net
Thu Aug 1 16:23:24 PDT 2013


Hi All, thanks for the replies so far..
I will try to address as many of them as I can in a group reply:

Xabier Oneca -- xOneca wrote:
Just to confirm, are you sure the scripts' path in config file is 
relative to the chroot directory?


- Yes, I am working under the new path names in my xml file.   The Web, 
Admin, and Log directories all work as planned.  The shell files are in 
the same path.

Jeff, I believe that answers your question as well.


"Thomas B. Rücker" wrote:

I guess you mean chown and chroot?
Or just chown, but no chroot?


/if/  I read this correctly, then this would mean, that it tries to run
connect.sh in the root directory of your chroot, so /connect.sh and when
seen from outside/home/<user>/icecast/connect.sh

Are there any security features on this system, that might interfere?
SELinux? AppArmor?

If all else fails, try to run this instead:
strace icecast -c/home/<user>/icecast/<config>.xml

==
- I was running both options, chroot and chown/grp.  I first ran under a chown/chgrp config in my xml.  I then added in the chroot flag to see if that had helped.   I don't think I gained any ground, because when I try and chroot from shell, I see this:
[~]# chroot /home/<user>/icecast
chroot: cannot run command `/bin/bash': No such file or directory

So let's just assume I should crawl before I can run.  From here on out I guess I'll leave chroot flag at 0

My chroot directory was setup as /home/<user>/icecast     The scripts are in /home/<user>/icecast   so in my xml I just reference /connect.sh as the script to run (no path).     When I don't chroot, I call script /home/<user>/icecast/connect.sh   and that still can't be located.   Yet, running a find ~ -name connect.sh from the user's account shows the full path just fine.

SELinux is disabled.   I don't believe I am running AppArmor.   This is a CentOS VPS (which I probably should have stated earlier).

I ran the strace.  It is well over my head.  If I capture it to a file, would you be willing to look it over for me?  I'm no linux noob, but I'm no where near being an expert either.


Thank you all for the help so far..
Phil
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.xiph.org/pipermail/icecast/attachments/20130801/b1267355/attachment-0001.htm 


More information about the Icecast mailing list