[Icecast] Problems with low frame rate streams

Gabor Kovesdan gabor at t-hosting.hu
Mon Sep 10 01:49:35 PDT 2012


Hi Thomas,

Em 07-09-2012 12:40, Rücker Thomas escreveu:
> Could you shed some more light on what the actual problem is?
> Icecast's behaviour, logs at debug level. Client software behaviour, etc.
> 
> Without that it's really hard to even guess what is going wrong...

I'm sorry if my first mail wasn't clear on this. In Icecast, I see this
mount point on the status page as if everyting were going fine, it even
detects the resolution and the 2.00 FPS. The only thing I see in the log
file is:

gabor at io:~$ tail /var/log/icecast2/error.log
[2012-09-10  10:42:27] INFO format-theora/initial_theora_page seen
initial theora header
[2012-09-10  10:42:29] INFO format-theora/initial_theora_page seen
initial theora header
[2012-09-10  10:42:31] INFO format-theora/initial_theora_page seen
initial theora header
[2012-09-10  10:42:32] INFO format-theora/initial_theora_page seen
initial theora header
[2012-09-10  10:42:33] INFO format-theora/initial_theora_page seen
initial theora header
[2012-09-10  10:42:35] INFO format-theora/initial_theora_page seen
initial theora header
[2012-09-10  10:42:36] INFO format-theora/initial_theora_page seen
initial theora header
[2012-09-10  10:42:37] INFO source/source_main listener count on
/full512.ogg now 1
[2012-09-10  10:42:38] INFO format-theora/initial_theora_page seen
initial theora header
[2012-09-10  10:42:39] INFO format-theora/initial_theora_page seen
initial theora header

The streamed video is created with ffmpeg and sent to icecast with
oggfwd. When I open this stream from the icecast status page with VLC,
it seems it is buffering but actually it will never start. If I increase
the FPS it just starts working or if instead of streaming, I write the
same low-FPS video into a file and I download it, VLC can play it
without problems.

Gabor


More information about the Icecast mailing list