[Icecast] *Bump* ices2 memory leak on Debian/ARM

The Darkener thedarkener at logicalnetworking.net
Mon Jan 2 13:21:27 PST 2012


Hi all,

I was really hoping to get a bit of help from this. I've since gone to
ezstream to try and accomplish the same goal, but ices2 is so simple to
use I would really like to stay with that instead.

Can anyone help me debug this memory leak? I can't use valgrind to try
and debug because it throws an "Illegal Instruction" whenever I try to
run it. :(


Happy New Year!
Jordan


On 12/15/2011 05:30 PM, TheDarkener wrote:
> Hi all.. I'm having a memory leak issue with Ices2 (using package
> 2.0.1-8 from Debian stable on arm platform)..
>
> I've tried turning off metadata, modifying samplerate, and some other
> misc. things that haven't helped. Eventually, during a stream, ices2
> will invoke oom-killer and bring the whole system down. It eats about
> 0.05MB/Sec of memory, so it takes a while, but this plug has 512mb, so
> about 2 hours into a stream, it will die.
>
> Any ideas? I can't seem to find anything online, especially regarding my
> arch. Nothing really shows up in the logs, even though I have ices set
> to 4 (debug) log output. I have a small portion of the strace output
> when running ices2... it keeps going, incrementing at the 'brk' calls...
> here: http://pastebin.com/5UHpM49s
>
> I have a system with identical configuration, only i386-based (an ASUS
> laptop). This system, with the same packages (but different arch)
> doesn't experience the memory leak.
>
> Any help or questions for me would be greatly appreciated :)
>
>
> Cheers,
> Jordan
>
>   


-- 
Jordan (PGP: 0xDA470FF8)



More information about the Icecast mailing list