[Icecast] Icecast start up script for icecast

Keith Roberts keith at karsites.net
Sun Feb 20 12:46:07 PST 2011


On Sun, 20 Feb 2011, Geoff Shang wrote:

> To: Luis Barrett <getpaid00 at gmail.com>
> From: Geoff Shang <geoff at QuiteLikely.com>
> Subject: Re: [Icecast] Icecast start up script for icecast
> 
> On Sun, 20 Feb 2011, Luis Barrett wrote:
>
>> We already have icecast install we our just trying to it 
>> started. In the icecast started script we need the 
>> icecast.pid file and we just want to know were in the 
>> directory is the icecast.pid file or do we have to create 
>> one if we do in which directory?
>
> The Icecast PID file will be created by Icecast itself when it is started.
>
> The location of the file is defined in the config file icecast.xml.
>
> If it's not there or commented out, it appears that no PID file is created
> (i.e. that there's no default location).  I say this because my running
> Icecast server on my home machine doesn't seem to have one and it's
> commented out in the config file.
>
> I guess you can put it anywhere, but there's probably a standard location
> for such things and it may even be specified in your config file.

Hi Geoff.

I'm running Centos 5.5 and the init process says icecast has 
started, but at shutdown time I get a message saying icecast 
is not running.

What needs to be edited in the icecast.xml to get it to 
startup at boot time please?

Regards,

Keith

-----------------------------------------------------------------
Websites:
http://www.karsites.net
http://www.php-debuggers.net
http://www.raised-from-the-dead.org.uk

All email addresses are challenge-response protected with
TMDA [http://tmda.net]
-----------------------------------------------------------------


More information about the Icecast mailing list