[Icecast] configuration & error help

Geoff Shang geoff at hitsandpieces.net
Sat May 19 21:02:02 PDT 2007


Hi,

A few questions.

1.  Which audio format are you using?

2.  When you are connecting your source client, what are you specifying 
(e.g. port, mountpoint)?  Does your source client have specific Icecast2 
support and is this enabled?

3.  If you call up http://server:port/status.xsl do you see your stream 
connected?

4.  When you attempt to play the stream, what do you enter as your location?

5.  Do you see anything in your error.log?

All this should help us diagnose your problem.

Geoff.


----- Original Message ----- 
From: "PsychicHigh" <psychichigh at evillight.net>
To: <icecast at xiph.org>
Sent: Saturday, May 19, 2007 10:01 PM
Subject: [Icecast] configuration & error help


Hi everybody, just a new face showing up looking for a little help
configuring IceCast.
Just installed the software with a few other programs in an attempt to
start off my own internet radio station.

Using SimpleCast to take the line-in and stream it to IceCast, which
in-turn does the obvious and streams it to the internet.

I'm looking at just creating a station of just 5 max users (for now) and
going to increase from there till I can find the limit my bandwidth can
hold. Though I've run into a bit of an error. Every player I load up in
attempt to listen to the radio, whether it's a remote client or local
client, I get a syncing error. Could this be caused by my
firewall/router setup? I've already forwarded the port I have set in the
configuration, but I'm a little lost.

Here is the configuration I am using:


<icecast>
    <limits>
        <clients>6</clients> <!-- since it seems SimpleCast is using up
a client spot... -->
        <sources>2</sources>
        <threadpool>5</threadpool>
        <queue-size>524288</queue-size>
        <client-timeout>30</client-timeout>
        <header-timeout>15</header-timeout>
        <source-timeout>10</source-timeout>
        <burst-on-connect>1</burst-on-connect>
        <burst-size>65535</burst-size>
    </limits>

    <authentication>
        <source-password>changeme</source-password>
        <relay-password>changeme</relay-password>
        <admin-user>admin</admin-user>
        <admin-password>changeme</admin-password>
    </authentication>

    <hostname>evillight.shacknet.nu</hostname>
    <listen-socket>
        <port>26487</port>
    </listen-socket>


    <fileserve>1</fileserve>

    <paths>
        <basedir>./</basedir>
        <logdir>./logs</logdir>
        <webroot>./web</webroot>
        <adminroot>./admin</adminroot>
        <alias source="/" dest="/status.xsl"/>
    </paths>

    <logging>
        <accesslog>access.log</accesslog>
        <errorlog>error.log</errorlog>
        <playlistlog>playlist.log</playlistlog>
          <loglevel>4</loglevel>
          <logsize>10000</logsize>
        <logarchive>1</logarchive>
    </logging>

    <security>
        <chroot>0</chroot>
    </security>
</icecast>


Very appreciative of the help. And, thanks in advance to everyone.
-- PsychicHigh // Clayton
_______________________________________________
Icecast mailing list
Icecast at xiph.org
http://lists.xiph.org/mailman/listinfo/icecast



More information about the Icecast mailing list