[Icecast] URL authentication

Peter Bengtson peter at peterbengtson.com
Fri Sep 8 03:56:28 PDT 2006


Isn't there anybody who has at least an idea what might be causing  
this? Or is URL authentication no longer considered a functional part  
of Icecast?

	/ Peter Bengtson

2 sep 2006 kl. 11.29 skrev Peter Bengtson:

> I can't get URL authentication to work. The notification script is  
> never called by icecast (v 2.3.1).
>
> This is the mount point:
>
>
>>     <mount>
>>         <mount-name>/tp.mp3</mount-name>
>>         <max-listeners>499</max-listeners>
>>         <hidden>1</hidden>
>>         <no-yp>1</no-yp>
>>         <authentication type="url">
>>             <option name="mount_add"       value="http:// 
>> wherever.tld/radio/notify.php"/>
>>             <option name="mount_remove"    value="http:// 
>> wherever.tld/radio/notify.php"/>
>>             <option name="listener_add"    value="http:// 
>> wherever.tld/radio/notify.php"/>
>>             <option name="listener_remove" value="http:// 
>> wherever.tld/radio/notify.php"/>
>>         </authentication>
>>     </mount>
>>
>
> This is what appears in the error log when a client connects:
>
>
>> [2006-09-02  11:10:36] INFO auth/add_client adding client for  
>> authentication
>> [2006-09-02  11:10:36] DBUG auth/add_client_to_source max on / 
>> tp.mp3 is 499 (cur 6)
>> [2006-09-02  11:10:36] DBUG auth/add_client_to_source Added client  
>> to /tp.mp3
>> [2006-09-02  11:10:36] DBUG auth/add_authenticated_client client  
>> authenticated, passed to source
>> [2006-09-02  11:10:36] DBUG stats/modify_node_event update node  
>> clients (8)
>> [2006-09-02  11:10:36] DBUG stats/modify_node_event update node  
>> connections (802)
>> [2006-09-02  11:10:36] DBUG stats/modify_node_event update node  
>> client_connections (801)
>> [2006-09-02  11:10:36] DBUG stats/modify_node_event update node  
>> listener_connections (19)
>> [2006-09-02  11:10:36] DBUG source/source_main Client added
>> [2006-09-02  11:10:36] INFO source/source_main listener count on / 
>> tp.mp3 now 7
>>
>
> All clients are added as authenticated, but the log files on  
> "wherever.tld" show that no access has been made.
>
> I have scoured the forums and the mailing list archives for answers  
> - every single page - and nobody has ever come up with a really  
> good explanation for this. WinAmp and password buffering have been  
> mentioned, but WinAmp is not running, has not been running, nor  
> will it ever be running, so there is no chance of password  
> buffering. Indeed, no passwords have yet every been passed with a  
> client connection. And this shouldn't in itself inhibit  
> authentication.
>
> It is difficult not to suspect an icecast 2.3.1 bug, but I'm still  
> hoping it is some sort of XML typo or unannounced spec change.
>
> I would be most grateful for any help or ideas. Thanks in advance,
>
> / Peter Bengtson
>
>
>
>
> _______________________________________________
> Icecast mailing list
> Icecast at xiph.org
> http://lists.xiph.org/mailman/listinfo/icecast



More information about the Icecast mailing list