[Icecast] Windows Xp / Icecast 2.3.1 / Oddcast 3 / Crap Router?

Leo Currie leo.currie at strath.ac.uk
Wed Apr 19 11:26:37 PDT 2006


Autoegocrat wrote:
> 
> 
> Ok here's the deal. I set up Icecast and Oddcast, got them to communicate
> properly, but cannot access the live audio remotely. On other computers in
> the LAN it works perfetly. Currently I operate wirelessly behind a D-Link
> 514 router (a mite outdated by now, yes?) and have opened all necessary
> ports, turned my firewalls off, set this computer as a DMZ, pretty much
> everything I can think of - but when I try to connect from outside the LAN,
> I still get a timeout message. I've check the access logs and ity does not
> show any record of a connection attempt. Perhaps this is a problem that is
> in a different league than icecast config, but you guys are smarter than I.
> Help me out? heh
> 

All that should be necessary to access the stream from the world is to 
open and forward the correct port on your router.

I was looking at this page:
http://support.dlink.com/faq/view.asp?prod_id=1005#604
..and it looks pretty straightforward, just click enable, name it 
something like "icecast", punch in the local IP of the machine on the 
LAN running Icecast, then the port it's running on twice (i.e. public & 
private the same), then click always, then apply. You shouldn't need to 
bother with any DMZ stuff or turning off firewalls.

You haven't by any chance got 2 lans, one wired, one wireless, and 
accidentally binded Icecast only to the wired nic, have you?
Just a thought...!

Leo


More information about the Icecast mailing list