[Icecast] ices2 metadata update causes gaps

Paul Martin pm at nowster.zetnet.co.uk
Tue Sep 27 03:38:32 PDT 2005


On Mon, Sep 26, 2005 at 07:50:59PM +0100, Paul Martin wrote:

> I've just taken a "savefile" from ices2. The bumps aren't happening. 
> It's got to be in icecast2!

It's definitely something in icecast. I've had a savefile coming out of 
ices2 and a dumpfile for the same stream out of icecast2.

Here's from ices2:

Vorbis stream 3:
        Total data length: 957707 bytes
        Playback length: 2m:57.094s
        Average bitrate: 43.262980 kbps
Logical stream 3 ended

And the same from icecast2:

Vorbis stream 3:
        Total data length: 960839 bytes
        Playback length: 2m:57.107s
        Average bitrate: 43.401440 kbps
Logical stream 3 ended


More from ices2 savefile:

Vorbis stream 4:
        Total data length: 1436445 bytes
        Playback length: 4m:06.090s
        Average bitrate: 46.696544 kbps
Logical stream 4 ended
Vorbis stream 5:
        Total data length: 892599 bytes
        Playback length: 2m:49.479s
        Average bitrate: 42.133741 kbps
Logical stream 5 ended

and the same from icecast2 dumpfile:

Vorbis stream 4:
        Total data length: 1440252 bytes
        Playback length: 4m:06.122s
        Average bitrate: 46.814092 kbps
Logical stream 4 ended
Vorbis stream 5:
        Total data length: 895785 bytes
        Playback length: 2m:49.508s
        Average bitrate: 42.276800 kbps
Logical stream 5 ended

>From somewhere, there's an extra 0.03 seconds of stream. It looks as if 
icecast is throwing in an extra (perhaps duplicated) frame from 
somewhere. (Tested with icecast2 2.2.0 and 2.3.0.)


-- 
Paul Martin <pm at zetnet.net> (work)
  <pm at nowster.zetnet.co.uk> (home)


More information about the Icecast mailing list