[Icecast] Unable to configure Ices with alsa for Creative Labs SB Audigy LS

Karl Heyes karl at xiph.org
Tue Nov 8 02:04:58 UTC 2005

Iceuse - Kris wrote:
> Hello,
> I have a computer with this sound card (from lspci):
> 0000:01:04.0 Multimedia audio controller: Creative Labs SB Audigy LS

> But when I put
> hw:0,0
> as input device, I'm getting
> [2005-11-07  21:53:19] EROR input-alsa/alsa_open_module Failed to open 
> audio device hw:0,0: No such device or address
> I tried many other values, hwplug:0,0 ... but still the same problem.
> Full input configuration is
>                <input>
>                        <!-- MODULE -->
>                        <module>alsa</module>
>                        <param name="device">hw:0,0</param>
>                        <param name="rate">44100</param>
>                        <param name="channels">1</param>
>                        <param name="periods">2</param>
>                        <param name="buffer-time">500</param>
>                        <param name="metadata">1</param>
>                        <param 
> name="metadatafilename">/usr/radio/meta/ices_live_metadata_live.txt</param>
>                </input>
> alsaconf is running fine, it finds my sound card and is happy.
> alsamixer seams to be fine also.

when you get these sorts of issues, check whether doing a simple record 
works as expected, eg arecord -f cd sample.wav (tweak parameters to 
match your settings).

> I'm stuck. And I don't know how to activate oss emulation as a fallback.

for the -kh tree define a second <input> block with OSS+parameters defined.


More information about the Icecast mailing list