[Icecast] problems with icecast/ices

Craig Meyer craig at fdllug.org
Fri Jun 3 07:42:51 PDT 2005


This is a very general email message. Please don't flame me on lack of 
information. I don't often get a chance to get into the building where 
this computer is located and unfortunately had turned logging off on the 
icecast server to avoid it ever writing to disk.

The problem:
Simply put, I have an icecast server on Linux that uses ices that needs 
to stream a signal 24/7 without interruptions. The client is a Windows 
98 machine that runs either Winamp 5 or Foobar2000 (I have tried both). 
What happens is suddenly (inside of 24 hours) the client program stops 
playing the stream and never reconnects without user intervention. 
However, as soon as I press the play button the client reconnects to the 
stream without issues. I am sure this is a problem with either the Linux 
box or icecast/ices on it. Prior to working with the Linux/Icecast box I 
used Shoutcast on Windows98 and didn't have this problem. Instead, I had 
Windows 98 crashing once every 2 to 3 months. Anyway, I expect to go 
onsite and look at the machine later today, when I do this I will turn 
on logging and get a copy of the config files (although they are fairly 
standard example files). What I am hoping for now is that someone is 
failure with possible problem(s) that could cause this. If someone could 
give me some idea of what to look for I appreciate it.

-Craig


More information about the Icecast mailing list