[Icecast] libshout build error

Michael Smith mlrsmith at gmail.com
Fri Jul 29 08:34:05 PDT 2005


On 7/29/05, Arthur Wiebe <artooro at gmail.com> wrote:
> When building libshout, configure outputs this error:

>  But I have the latest svn source installed of both ogg and vorbis.

>  
>  I'm using gcc 4.0.

I have no answer to your actual question, since I don't claim to have
much idea about autoconf, but this sounds like you compiled libvorbis
with gcc4.

For the moment, you shouldn't do that, or you must compile with at
most -O2, not -O3 (which libvorbis is compiled with by default). gcc4
badly miscompiles libvorbis at -O3 (or triggers a latent libvorbis
bug, we're not yet sure which).

Mike


More information about the Icecast mailing list