[Icecast] build libshout and icecast under Windows

Yi Liang yjliang99 at yahoo.com
Thu Jul 14 14:32:57 PDT 2005


Thanks Oddsock.
Acutally my VC 7 (.net) did convert the VC 6 project
files properly. But you think most problems may come
from the incompatibility of VC 7, instead of from the
required libraries and etc.?

If compiling in VC 6 is generally smooth, I would
rather roll back to VC 6. Thanks.

Yi

--- oddsock <oddsock at oddsock.org> wrote:

> Sorry, but both icecast and libshout only have VC6
> project files.   I have 
> no desire to create and maintain VS.NET project
> files as well...
> 
> oddsock
> At 12:39 AM 7/14/2005, you wrote:
> >Hi folks, I'm kinda new on the list.
> >
> >I've been trying to build libshout 2.1 and then
> >icecast 2.2.0 under Windows, using Visual Studio
> 7.0
> >(.net), but had lots of problems.
> >
> >I've fetched needed packages including curl, iconv,
> >libxml2, libxslt, org, pthreads, theora, but I
> still
> >cannot find "implement.h", and the build reports
> >errors at linking such as "invalid or corrupt
> file".
> >
> >Does any one have experience on building under
> >Windows, and can refer me further resources?
> Anywhere
> >to download the complete source package that can be
> >built smooth under Windows? Your help is greatly
> >appreciated.
> >
> >Best,
> >Yi
> >_______________________________________________
> >Icecast mailing list
> >Icecast at xiph.org
> >http://lists.xiph.org/mailman/listinfo/icecast
> 
> 
> _______________________________________________
> Icecast mailing list
> Icecast at xiph.org
> http://lists.xiph.org/mailman/listinfo/icecast
> 



More information about the Icecast mailing list