[icecast] No sound (ices-2.0.0, RH9)

Geoff Shang gshang at pacific.net.au
Sat Mar 27 04:57:35 PST 2004



Hi:

Your ability to use this setup is going to depend on whether or not your
card can capture its own output, or at least its own PCM output.  Since
you're using the OSS drivers, try running the following command:

aumix -q

This wil list the settings for each channel.  a P flag denotes a device set
to playback only, an R flag denotes a device that you can record from.
Some cards will allow you to record from more than one channel at a time,
so be aware of this.  You need to see if you can set your PCM device to let
you record from it.  Unfortunatly, aumix doesn't let you see the
capabilities of channels, unlike alsa's amixer, so you're going to have to
experiment with it.  It's possible it doesn't, and even if it does, the OSS
drivers mightn't provide that fascility - I really don't know.

So, assuming it does, you could try:

aumix -w r

Note that I don't use aumix, now that I use alsa, so I'm not really that
familiar with it.

Having said all that, it's probably far simpler to use Oddcast for XMMS if
you're playing the music with XMMS anyway.  Get it from
http://www.oddsock.org/tools/oddcastv2_xmms

Geoff.

<p>--- >8 ----
List archives:  http://www.xiph.org/archives/
icecast project homepage: http://www.icecast.org/
To unsubscribe from this list, send a message to 'icecast-request at xiph.org'
containing only the word 'unsubscribe' in the body.  No subject is needed.
Unsubscribe messages sent to the list will be ignored/filtered.



More information about the Icecast mailing list