[icecast] Bizarre (and irritating) ices2 error

M Edwards medwards at ualberta.ca
Sun Feb 29 23:42:17 PST 2004



I get this error every time I try to start ices:

ices: relocation error: ices: undefined symbol: resolver_initialize

I'm running a Celeron with 64MB of RAM which up until last moth, ran ices with 
absolutely no complaint.

Here are the steps I've taken to resolve this problem:
Full update from debian/unstable
-no effect
Full reinstall of all dependencies using CVS checkouts
-ices fails to compile claiming libshout isn't thread-safe. I've done 
everything in my power to make sure the libraries are there for libshout and 
during its ./configure run it appears to find -pthread (or whatever the fourth 
option is)
Installation of libshout3 and ices2 debian packages from Keegan's site
-no effect

There is absolutely no documentation on this error from google. In fact the 
closest I get is a CVS examination of a commit included ices.c 
(http://www.xiph.org/archives/cvs/3587.html) where resolver_initalize is 
REMOVED in favor of shout_init (if my reading is correct).

So I'm very confused. I've probably lost huge segments of my listening 
population to date and was hoping that finally having some time to put towards 
fixing the error might result in an answer. But it hasn't.

--thanks
Michael Edwards
http://www.walledcity.ca/mars

<p>--- >8 ----
List archives:  http://www.xiph.org/archives/
icecast project homepage: http://www.icecast.org/
To unsubscribe from this list, send a message to 'icecast-request at xiph.org'
containing only the word 'unsubscribe' in the body.  No subject is needed.
Unsubscribe messages sent to the list will be ignored/filtered.



More information about the Icecast mailing list