[icecast] MB soundcards and PCI soundcards

Adam D. Ligas adam at physco.com
Mon Feb 9 20:35:16 PST 2004



Kerry,

I have two soundcards in my system, using RH 7.3, and I had a hell of a time 
getting the second one to work.  I think it was because I added the second one 
after I installed the machine.  I'm not sure anything I am about to say will 
help your case, but what the hell :).

My first problem was that I had /dev/dsp and /dev/dsp1, but both pointed to 
the same sound card.  Apparantly, this is because I am using a SB Live, and it 
uses two dsps.  So although I thought I saw two cards, I really only had one 
usable.

Once I made sure the module was loaded and running properly, I had to create 
two new /dev entries for the card to use - dsp2 and dsp3.  I did that with the 
following two lines:

mknod /dev/dsp2 c 14 35
mknod /dev/dsp3 c 14 51

After I did that, pointing my streamer (in my case DarkIce) at /dev/dsp2 got 
me access to the second card.

I also had to use aumix on /dev/mixer1 to set the levels on that second card.  
It defaulted the input to mute on me, so I wasn't getting anything at first.  
Unmuting it and boosting the level got me in business.

Maybe your RH install took the onboard sound and mapped it to the dsp and dsp1 
entries.  Maybe it preserves that mapping even though the card is "disabled" 
and is treating the new soundboard like a "second" card?

- Adam

Quoting Kerry Cox <kerry.cox at ksl.com>:

> Here's a problem that I have uncovered on two entriely separate machines
> using the latest icecast2 and ices2 software. Even when the onboard
> soundcard is disabled, the PCI soundcard (which has been both a Creative
> Live! and an Ensoniq soundcard) is unable to accept input or stdin
> audio.
> If I enable the onboard soundcard everything works well and I can stream
> audio using icecast and ices. But using the PCI soundcard with the
> onboard card disabled, no input is detected.
> I have tested this so far on only RH9 with the latest updates.
> Has anyone else come across this, and if so, how did they fix this? Not
> a big issue, but I would like to use the nicer soundcards rather than
> the built-in cards.
> Thanks.
> KJ
--- >8 ----
List archives:  http://www.xiph.org/archives/
icecast project homepage: http://www.icecast.org/
To unsubscribe from this list, send a message to 'icecast-request at xiph.org'
containing only the word 'unsubscribe' in the body.  No subject is needed.
Unsubscribe messages sent to the list will be ignored/filtered.



More information about the Icecast mailing list