[icecast] autogen.sh trouble with latest CVS checkout

Tano M Fotang fotang at yahoo.com
Fri Sep 12 10:52:59 PDT 2003



Hello All:
I just checked out the whole icecast but cannot build anything because 
autogen wouldn't cooperate. I have automake-1.7.6 just installed from 
ftp.gnu.org. Below is an example output in trying to build "icecast"; 
it's not very short... Thanks in advance for any help.


---

$~/icecast/icecast> ./autogen.sh
Checking for automake version
  found automake
  found aclocal
Generating configuration files for ices, please wait....
  aclocal  -I m4
aclocal: configure.in: 13: macro `AM_PROG_LIBTOOL' not found in library
  autoheader
autoheader: error: AC_CONFIG_HEADERS not found in configure.in
  libtoolize --automake
  automake --add-missing
configure.in: no proper invocation of AM_INIT_AUTOMAKE was found.
configure.in: You should verify that configure.in invokes AM_INIT_AUTOMAKE,
configure.in: that aclocal.m4 is present in the top-level directory,
configure.in: and that aclocal.m4 was recently regenerated (using aclocal).
/usr/local/share/automake-1.7/am/depend2.am: am__fastdepCC does not 
appear in AM_CONDITIONAL
/usr/local/share/automake-1.7/am/depend2.am: AMDEP does not appear in 
AM_CONDITIONAL
src/avl/Makefile.am:7: Libtool library used but `LIBTOOL' is undefined
src/avl/Makefile.am:7:
src/avl/Makefile.am:7: The usual way to define `LIBTOOL' is to add 
`AC_PROG_LIBTOOL'
src/avl/Makefile.am:7: to `configure.in' and run `aclocal' and 
`autoconf' again.
/usr/local/share/automake-1.7/am/depend2.am: am__fastdepCC does not 
appear in AM_CONDITIONAL
/usr/local/share/automake-1.7/am/depend2.am: AMDEP does not appear in 
AM_CONDITIONAL
src/httpp/Makefile.am:5: Libtool library used but `LIBTOOL' is undefined
src/httpp/Makefile.am:5:
src/httpp/Makefile.am:5: The usual way to define `LIBTOOL' is to add 
`AC_PROG_LIBTOOL'
src/httpp/Makefile.am:5: to `configure.in' and run `aclocal' and 
`autoconf' again.
/usr/local/share/automake-1.7/am/depend2.am: am__fastdepCC does not 
appear in AM_CONDITIONAL
/usr/local/share/automake-1.7/am/depend2.am: AMDEP does not appear in 
AM_CONDITIONAL
src/log/Makefile.am:7: Libtool library used but `LIBTOOL' is undefined
src/log/Makefile.am:7:
src/log/Makefile.am:7: The usual way to define `LIBTOOL' is to add 
`AC_PROG_LIBTOOL'
src/log/Makefile.am:7: to `configure.in' and run `aclocal' and 
`autoconf' again.
/usr/local/share/automake-1.7/am/depend2.am: am__fastdepCC does not 
appear in AM_CONDITIONAL
/usr/local/share/automake-1.7/am/depend2.am: AMDEP does not appear in 
AM_CONDITIONAL
src/net/Makefile.am:7: Libtool library used but `LIBTOOL' is undefined
src/net/Makefile.am:7:
src/net/Makefile.am:7: The usual way to define `LIBTOOL' is to add 
`AC_PROG_LIBTOOL'
src/net/Makefile.am:7: to `configure.in' and run `aclocal' and 
`autoconf' again.
/usr/local/share/automake-1.7/am/depend2.am: am__fastdepCC does not 
appear in AM_CONDITIONAL
/usr/local/share/automake-1.7/am/depend2.am: AMDEP does not appear in 
AM_CONDITIONAL
src/thread/Makefile.am:7: Libtool library used but `LIBTOOL' is undefined
src/thread/Makefile.am:7:
src/thread/Makefile.am:7: The usual way to define `LIBTOOL' is to add 
`AC_PROG_LIBTOOL'
src/thread/Makefile.am:7: to `configure.in' and run `aclocal' and 
`autoconf' again.
/usr/local/share/automake-1.7/am/depend2.am: am__fastdepCC does not 
appear in AM_CONDITIONAL
/usr/local/share/automake-1.7/am/depend2.am: AMDEP does not appear in 
AM_CONDITIONAL
src/timing/Makefile.am:7: Libtool library used but `LIBTOOL' is undefined
src/timing/Makefile.am:7:
src/timing/Makefile.am:7: The usual way to define `LIBTOOL' is to add 
`AC_PROG_LIBTOOL'
src/timing/Makefile.am:7: to `configure.in' and run `aclocal' and 
`autoconf' again.
/usr/local/share/automake-1.7/am/depend2.am: am__fastdepCC does not 
appear in AM_CONDITIONAL
/usr/local/share/automake-1.7/am/depend2.am: AMDEP does not appear in 
AM_CONDITIONAL
  autoconf
I am going to run ./configure with no arguments - if you wish
to pass any to it, please specify them on the ./autogen.sh command line.
./configure: AM_INIT_AUTOMAKE: command not found
./configure: line 1283: syntax error near unexpected token 
`AM_CONFIG_HEADER(config.h)'
./configure: line 1283: `AM_CONFIG_HEADER(config.h)'

<p>--- >8 ----
List archives:  http://www.xiph.org/archives/
icecast project homepage: http://www.icecast.org/
To unsubscribe from this list, send a message to 'icecast-request at xiph.org'
containing only the word 'unsubscribe' in the body.  No subject is needed.
Unsubscribe messages sent to the list will be ignored/filtered.




More information about the Icecast mailing list