[icecast] Trouble getting Ices/Icecast2 to stream

Morgan Grammer morgang at newlifemedia.org
Fri Mar 21 19:51:45 PST 2003



Mike / Karl -

I've tried two different ways of setting up the "stream". In one URL, I
named the file directly (http://foo.bar.org:8001/stream.ogg), and in the
second, I made a stream.m3u file containing the afore mentioned http
statement. Neither worked in Winamp. I had downloaded version 3 of
WinAmp, so I uninstalled that, and went out and got the JOrbis (Java)
player and the latest JRE from Sun. I also downloaded JlGui to see if
either one of those would see the live stream. Neither did.

I have yet (since I've written the first email) to segfault icecast
again, however I have been able to make Ices lock up and ignore a -KILL
or -HUP signal. This usually happens after I launch Ices once
interactively rather than making it a background process. After I kill
it to make a change, and then start it up again, it only partially
starts and then hangs. A system reboot seems to fix the problem.

I'll forward my config file to you privately along with the error log.
Its not consistent, so I'm still trying to figure out exactly what
causes the segfault.

-Morgan

<p>-----Original Message-----
From: owner-icecast at xiph.org [mailto:owner-icecast at xiph.org] On Behalf
Of Michael Smith
Sent: Friday, March 21, 2003 6:21 PM
To: icecast at xiph.org
Subject: Re: [icecast] Trouble getting Ices/Icecast2 to stream

On Saturday 22 March 2003 04:28, Morgan Grammer wrote:
> I'm rather new to this. I just set up Icecast and Ices using source
from
> CVS downloaded yesterday (3-20-2003). The box is running RedHat 8.0
with
> all the required RPMs to compile. Here's my trouble:
>
> I have Ices running in live mode, with it connecting correctly to the
> Icecast server on port 8000 (which is only bound to 127.0.0.1). I'm
> using Winamp on the client end connecting to port 8001 (which is only
> bound to my outside IP). Winamp will connect, say it has completed
> prebuffering, and I see data moving, but there is no audio. If I
include
> "savefile" in the Ices config, it will correctly write the file, which
I
> can load into winamp and hear audio.

Winamp (and several other common media players) have a serious bug in
their 
HTTP streaming implementation, which means it treats everything as mp3. 
There's a hack in the vorbis plugin to treat it as vorbis if (and only
if) 
the URL ends with ".ogg" - does yours? This sounds like what happens if
you 
don't.

>
> If I try to listen to the "savefile" by connecting to the web portion
of
> Icecast, it will occasionally work, but 8 out of 10 times, icecast
will
> segfault.

Eek. That should _never_ happen, can you give further details, including
your 
icecast config file?

Mike

--- >8 ----
List archives:  http://www.xiph.org/archives/
icecast project homepage: http://www.icecast.org/
To unsubscribe from this list, send a message to
'icecast-request at xiph.org'
containing only the word 'unsubscribe' in the body.  No subject is
needed.
Unsubscribe messages sent to the list will be ignored/filtered.

--- >8 ----
List archives:  http://www.xiph.org/archives/
icecast project homepage: http://www.icecast.org/
To unsubscribe from this list, send a message to 'icecast-request at xiph.org'
containing only the word 'unsubscribe' in the body.  No subject is needed.
Unsubscribe messages sent to the list will be ignored/filtered.



More information about the Icecast mailing list