[icecast] My turn to have issues with compiling libshout

Karl Heyes karl at pts.tele2.co.uk
Thu Mar 13 08:31:03 PST 2003



On Thu, 2003-03-13 at 15:33, Geoff Shang wrote:
> Hi:
> 
> WARNING: This is long.
> 
> Just updated libshout and configured.  Configure didn't bomb so I guess it
> went OK and found what it wanted. But when I ran make I got this:
> 
> gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I./.. -g -O2 -Wp,-MD,.deps/avl.pp -c
> avl.c
>   -fPIC -DPIC -o .libs/avl.lo
> In file included from ../stream.h:20,
>                  from ../config.h:17,
>                  from avl.c:33:
> ../thread/thread.h:90: syntax error before "pthread_rwlock_t"

This is the key point, what system is this, and can you send me the
config.log

> I suspect this is another simptom of the threads stuff that's being worked
> on.  I suspect I'm missing something important, something configure wasn't
> too bothered about however.

yep, although I'm surprised configure passed this bit though. the
config.log will explain more.

<p>karl.

<p><p>--- >8 ----
List archives:  http://www.xiph.org/archives/
icecast project homepage: http://www.icecast.org/
To unsubscribe from this list, send a message to 'icecast-request at xiph.org'
containing only the word 'unsubscribe' in the body.  No subject is needed.
Unsubscribe messages sent to the list will be ignored/filtered.



More information about the Icecast mailing list