[icecast] compilling error ices-0.2.3 cvs

Brendan Cully brendan at xiph.org
Tue Mar 11 11:05:02 PST 2003



On Sunday, 09 March 2003 at 01:53, ronnie at mixsessions.com wrote:
> 
> Brendan Cully wrote:
> >This particular error is because you used --with-libshout= instead of --with-libshout
> 
> Is the above a typo. They look the same with the exception of the "=". I am new to linux so please
> be forgiving.

Don't type it with the '=' alone. Only use '=' if you want to put something after it.

> I downloaded both ices and libshout. I tried to compile with "--with-shout-config=/etc/stream" but
> this returned the same result as in the previous email:
>  "checking for shout_new in -lshout... no
>  configure: error: Could not find a usable installed libshout".
> 
> So I tried "--with-libshout=/etc/stream" and this time it did work.Yeah! BUT when I did make I

this doesn't do anything - you would have gotten the same results by just typing
./configure

but --with-shout-config expected the path to a program named shout-config, eg:
--with-shout-config=/usr/local/bin/shout-config

Since you gave it no explicit instructions, it found that one by itself.

ANYway...

> setup.c: In function `ices_setup_parse_config_file':
> setup.c:251: `ICES_ETCDIR' undeclared (first use in this function)

This was an automake issue (CVS source expected automake 1.7). It should be
fixed now, so update and try again.

Alternatively you can try the snapshot available at:

http://www.icecast.org/~brendan/

-b

--- >8 ----
List archives:  http://www.xiph.org/archives/
icecast project homepage: http://www.icecast.org/
To unsubscribe from this list, send a message to 'icecast-request at xiph.org'
containing only the word 'unsubscribe' in the body.  No subject is needed.
Unsubscribe messages sent to the list will be ignored/filtered.



More information about the Icecast mailing list