[icecast] CVS ices 0.x problems

Brendan Cully brendan at xiph.org
Thu Mar 6 17:03:13 PST 2003



On Thursday, 06 March 2003 at 19:58, Adon Irani wrote:
> 
> i have a recent libshout cvs-snapshot working fine .
> 
> but when i try to compile ices 0.x cvs :: i get this .,
> 
> -
> 
> ...Compiling with CPPFLAGS= -I/usr/include/libxml2/libxml
> -I/usr/include/libxml2
> Linking with LDFLAGS=  -lxml2 -lmp3lame -lvorbisfile -lvorbis -logg -lm
> Features:
>   libshout: builtin
>   LAME    : yes
>   Vorbis  : yes
>   Perl    : no
>   Python  : no
>   XML     : yes
> 
> mystifLY:/usr/src/ices# make
> Making all in libshout
> /bin/sh: cd: libshout: No such file or directory
> make: *** [all-recursive] Error 1
> 
> --
> 
> i realize that the libshout: builtin is prolly the problem . but i am
> unable to get the ./autogen.sh er ./configure to recognize this installed
> libshout .

In cvs there is no libshout builtin at the moment (that will be fixed before
release). But it should have no problems using an installed version.

I'm assuming you tried --with-libshout=/path/to/my/libshout ?

You should just need to tell configure where you installed your version.

If you're sure you're giving it the right path, it may be that there's an
older version of libshout somewhere earlier in gcc's search path.

The easiest way to debug would be to jump onto irc.xiph.org, channel #icecast.

Otherwise mail me your config.log and configure arguments, plus the arguments
you used to build and install libshout.
--- >8 ----
List archives:  http://www.xiph.org/archives/
icecast project homepage: http://www.icecast.org/
To unsubscribe from this list, send a message to 'icecast-request at xiph.org'
containing only the word 'unsubscribe' in the body.  No subject is needed.
Unsubscribe messages sent to the list will be ignored/filtered.



More information about the Icecast mailing list