[icecast] Using icecast2 with MP3 problems

Shawn M Ferris shawnmferris at yahoo.com
Sun Mar 2 22:42:13 PST 2003



> libshout: :pserver:anoncvs at cvs.xiph.org:/usr/local/cvsroot
> ices: :pserver:anoncvs at cvs.xiph.org:/cvs/ice
> 
> Check out the ices-libshout_2 branch of ices.

Libshout compiles fine, but ices wont configure correctly. It wouldn't
find shout_new in libshout, lame_encode_flush_nogap in mp3lame 
nor ov_open in libvorbisfile.. (nor is libtool found, but I copied it 
from libshout.)

But yet:
$ nm /opt/ice/lib/libshout.so | grep shout_new
00003e38 T shout_new

$ nm /usr/lib/libmp3lame.so | grep lame_encode_flush_nogap
000145e8 T lame_encode_flush_nogap

$ nm /usr/lib/libvorbisfile.so | grep ov_open
00002cd0 T ov_open

I'm chalking this up to compiler configuration? yet, if I trick it,
everything compiles fine. But.. I still can't get ices to communicate
with icecase:

>From icecast/error.log (Incidently, i've not gotten any messages other than
this. The one from ices.log changes as I make progress)
[2003-03-02  23:37:39] EROR connection/_handle_connection HTTP request parsing failed

>From ices.log
Error during send: Mount failed on http://192.168.0.1:8000/ices.mp3, error: Socket error

Any help, anyone? I know enough c to be dangerous and Im guessing Im getting out
of my league now.. Should I concentrate my efforts on icecast1?  Or continue
to hack at it.

Thanks again!
SMF 8)

<p><p>--- >8 ----
List archives:  http://www.xiph.org/archives/
icecast project homepage: http://www.icecast.org/
To unsubscribe from this list, send a message to 'icecast-request at xiph.org'
containing only the word 'unsubscribe' in the body.  No subject is needed.
Unsubscribe messages sent to the list will be ignored/filtered.



More information about the Icecast mailing list