[icecast] LiveIce/IceCast Error

Mathias Gygax mg at trash.net
Sun Jan 5 20:26:58 UTC 2003

On Sun, Jan 05, 2003 at 11:14:00AM -0800, Bryan D. Brown wrote:
> Greetings everyone....

hi bryan,

> I tried posting this once before, but got no response.
> When I run liveice, I get an "Error:sending data to remote server 
> message" from liveice, and then it hangs (I actually have to open 
> another console window to kill the process).
> The IceCast server respond with the following:
> Kicking source 1 [] [Access Denied (tcp wrappers (source 
> connection))] [encoder], connected for 1 seconds, 0 bytes transfered. 
> -1 sources connected

you try to access the encoder module via localhost (

> I am pretty sure this has to do with the permissions settings in both 
> the hosts.allow file and the icecast.conf  file, but I am not sure 
> what to change (I can access the IceCast admin window without a 
> problem).

try to put the following line into /etc/hosts.allow

icecast: LOCAL

if this doesn't work, put the tcp port number (80 in your case) in the
beginning instead the name of the daemon.


you can extend the middle part (LOCAL) with all your ips or subnets
which should be allowed to access the encoder module.

i guess you have a somewhat similar line in /etc/hosts.deny like this:


this does lock out every tcp connection to all daemons which are linked
against libwrap or started with tcpd(8) (e.g. inetd programs does this
usually). do something against it and fix your /etc/hosts.allow.

if it still doesn't work, check out tcp_wrapper settings with tcpdchk.
see manual page for syntax.

> opening connection to localhost 80

this is alright.

> -> [20/Dec/2002:10:35:45] Listening on port 80...

this is ok.

> -> [20/Dec/2002:10:36:07] Kicking source 1 [] [Access Denied 
> (tcp wrappers (source connection))] [encoder], connected for 1 
> seconds, 0 bytes transfered. -1 sources connected

if i interpret the error right, its using the tcp_wrappers (libwrap)
library to check for access permissions and is not using its internal
ACL scheme) and you try to connect to icecast server via tcp port 80 on
the localhost. fix your tcp_wrappers settings

read more about tcp_wrappers in the following manual pages:

tcpd (8)             - access control facility for internet services
tcpdchk (8)          - tcp wrapper configuration checker
hosts_access (5)     - format of host access control files
hosts_access (3)     - access control library
hosts_options (5)    - host access control language extensions

if it still doesn't work, check the internal ACL settings of icecast in


 - regards from switzerland, turrican
--- >8 ----
List archives:  http://www.xiph.org/archives/
icecast project homepage: http://www.icecast.org/
To unsubscribe from this list, send a message to 'icecast-request at xiph.org'
containing only the word 'unsubscribe' in the body.  No subject is needed.
Unsubscribe messages sent to the list will be ignored/filtered.

More information about the Icecast mailing list