[icecast] Compiling icecast2, libcurl problem

Leo Willner l.willner at kabsi.at
Sat Aug 30 06:56:20 PDT 2003



Hi there,

I got a question regarding compiling the icecast2-server:

        When I'm executing the 'sh autogen.sh' command and is checking for libraries, it says that it didn't find the 'libcurl' library, although I have the curl-rpm installed 
that includes the libcurl (located in /usr/lib). I compiled icecast2 anyway and tried running it. If I try to get the status.xsl the browser says it found the page, but isn't able 
to download it. Something similar happens when I try to get an ogg-stream. I wrote /usr/lib to my 'ld.so.conf', but with no effect on the sh autogen.sh'-command.

As far as I know curl and libcurl has something to do with file-transfer, so I think it may be the reason for the male-function.

If the absence of libcurl is the reason for this, maybe somebody knows how to tell the 'sh autogen.sh'-command or gcc the location of my 'libcurl' (located in /usr/lib). 
Maybe it has something to do with a linker or so ? I have no experiences in C-compiling.

I'm using SuSE Linux 8.2 Professional with a standard software installation. The suse-rpms libxml, libxslt, libvorbis, libogg, libao and curl (with the libcurl) and their devel-
counterparts are installed. Vorbis-tools-rpm is installed too.. 

Tanks for your help.
                Leo

<p><p>--- >8 ----
List archives:  http://www.xiph.org/archives/
icecast project homepage: http://www.icecast.org/
To unsubscribe from this list, send a message to 'icecast-request at xiph.org'
containing only the word 'unsubscribe' in the body.  No subject is needed.
Unsubscribe messages sent to the list will be ignored/filtered.



More information about the Icecast mailing list