[icecast] Icecast2 and IceS2 client problem

jeff at unsealed.net jeff at unsealed.net
Tue Apr 8 12:40:29 PDT 2003



Dear All:

I have Icecast2 and IceS2 successfully built and installed on a Debian 3.0 
system. After tinkering with the config files, both applications are running 
and seem to be talking to each other without problem. However, when I try to 
connect with a client, I run into problems: with Winamp 2.8, I get an [HTTP/1.0 
200 OK] message, but then the stream is apparently dropped before buffering. 
With XMMS 1.2.7, the client connects, the stream is buffered, but then dropped, 
and rebuffered, ad infinitum. Any ideas??

from logfiles:

[Icecast access.log]
10.10.20.21 - - [08/Apr/2003:12:13:17 -0700] "GET /ogg HTTP/1.0" 200 9643333 "-
" "xmms/1.2.7" 805
10.10.20.11 - - [08/Apr/2003:12:14:33 -0700] "GET /ogg HTTP/1.0" 200 10455570 "-
" "WinampMPEG/2.8" 859

[Icecast error.log]
[2003-04-08  12:14:33] DBUG connection/_handle_get_request Client connected
[2003-04-08  12:14:33] DBUG connection/_handle_get_request Source found for 
client
[2003-04-08  12:14:33] DBUG source/source_main Client had unrecoverable error 
with new data, probably due to client disconnection
[2003-04-08  12:14:33] DBUG source/source_main Client removed
[2003-04-08  12:14:33] DBUG source/source_main Client added

[ices.log]
[2003-04-08  12:16:34] INFO playlist-builtin/playlist_read Currently 
playing /opt/media/music/Abstract Rude & Tribe Unique - Heavyweights Round 4.ogg
[2003-04-08  12:16:35] DBUG encode/encode_clear Clearing encoder engine
[2003-04-08  12:16:35] DBUG reencode/reencode_page Reinitialising reencoder for 
new logical stream
[2003-04-08  12:16:35] INFO encode/encode_initialise Encoder initialising in 
VBR mode: 2 channel(s), 44100 Hz, quality 3.000000
 (etc., etc., etc.)

relevant netstat output:
tcp        0      0 10.10.20.4:8000         0.0.0.0:*               LISTEN
tcp        0      0 10.10.20.4:33300        10.10.20.4:8000         ESTABLISHED 
tcp        0  14314 10.10.20.4:8000         10.10.20.21:1028        FIN_WAIT1   
tcp        0      0 10.10.20.4:8000         10.10.20.4:33300        ESTABLISHED 
tcp        0   1355 10.10.20.4:8000         10.10.20.11:3822        ESTABLISHED 

(10.10.20.21 is a debian system running xmms, and 10.10.20.11 is a winXP system 
running Winamp 2.8. 10.10.20.4 is the Icecast server listening on 8000, and 
33300 is the IceS socket, presumeably)

from ps ax:
11415 pts/2    S      0:00 /usr/local/bin/icecast -
c /usr/local/icecast2/conf/icecast.xml
11416 pts/2    S      0:00 /usr/local/bin/icecast -
c /usr/local/icecast2/conf/icecast.xml
11417 pts/2    S      0:00 /usr/local/bin/icecast -
c /usr/local/icecast2/conf/icecast.xml
11418 pts/2    S      0:00 /usr/local/bin/icecast -
c /usr/local/icecast2/conf/icecast.xml
11419 pts/2    S      0:00 /usr/local/bin/icecast -
c /usr/local/icecast2/conf/icecast.xml
11420 pts/2    S      0:00 /usr/local/bin/icecast -
c /usr/local/icecast2/conf/icecast.xml
11421 pts/2    S      0:00 /usr/local/bin/icecast -
c /usr/local/icecast2/conf/icecast.xml
12057 pts/2    S      0:00 ices test.xml
12058 pts/2    S      0:00 ices test.xml
12059 pts/2    S      6:26 ices test.xml

the winamp client/windows machine has established a persistent connection, and 
lots of acks go flying by on a tcpdump, but nothing happens. the debian/xmms 
client tries for a while before giving up (but without sending a fin...). I 
should probably mention that both of these clients have no trouble connecting 
to an Icecast 1.3.12 stream, nor do they have a problem with static fileserving 
on the Icecast2 server.

thanks in advance.

Jeff Garnand
--- >8 ----
List archives:  http://www.xiph.org/archives/
icecast project homepage: http://www.icecast.org/
To unsubscribe from this list, send a message to 'icecast-request at xiph.org'
containing only the word 'unsubscribe' in the body.  No subject is needed.
Unsubscribe messages sent to the list will be ignored/filtered.



More information about the Icecast mailing list