[icecast] ices configure script

Brendan Cully brendan at icecast.org
Sun Mar 24 20:40:00 UTC 2002

On Saturday, 16 March 2002 at 12:14, Alex Gutteridge wrote:
> Hi,
> I'm having difficulty getting ices 0.2.2 to see my lame install and my 
> perl install. The lame libraries (v3.91) are installed in: 
> /usr/local/lib/ with the header file at: /usr/local/include/lame/lame.h, 
> but when I run:
> ./configure --with-lame --with-lame-includes=/usr/local/include/lame/ 
> --with-lame-libraries=/usr/local/
> it says it can't find the lame libraries. ldconfig seems to show they're 
> installed:
> libmp3lame.so.0 (libc6) => /usr/local/lib/libmp3lame.so.0

Uh, that's kind of odd. It should be pointing to something like

Can you do ls -l /usr/local/lib/libmp3lame*

> libmp3lame.so (libc6) => /usr/local/lib/libmp3lame.so
> I get the same problem with the --with-perl option - I have perl 
> installed in the normal place (/usr/bin/perl) but when I try 
> --with-perl=/usr it says is can't find /usr/bin/perl (no such file). 
> I've intalled Ices fine withoutthese options, but I'd really like to get 
> it working with the re-encoding and perl. What am I doing wrong?

ices should search both of these directories by default, so you
shouldn't have to provide any options to get perl and lame. In a pinch,
--with-lame=/usr/local ought to do. The --with-perl option ought to have
worked. Can you send the actual output from configure where these tests


--- >8 ----
List archives:  http://www.xiph.org/archives/
icecast project homepage: http://www.icecast.org/
To unsubscribe from this list, send a message to 'icecast-request at xiph.org'
containing only the word 'unsubscribe' in the body.  No subject is needed.
Unsubscribe messages sent to the list will be ignored/filtered.

More information about the Icecast mailing list