[icecast] ices stdinpcm

smoerk smoerk at gmx.de
Mon Dec 2 16:11:46 PST 2002



I testetd it with winamp2 and ogg123, didn't work. cpu usage was around 
30% or 35%. the version is from yesterday.

this is my config file:

<?xml version="1.0"?>
<ices>
         <logpath>ices</logpath>
         <logfile>ices.log</logfile>
         <loglevel>4</loglevel>
         <consolelog>4</consolelog>
         <stream>
                 <metadata>
                         <name>Example stream name</name>
                         <genre>Example genre</genre>
                         <description>A short description</description>
                 </metadata>
                 <input>
                         <module>stdinpcm</module>
                         <param name="rate">48000</param>
                         <param name="channels">2</param>
                 </input>
                 <instance>
                         <hostname>radiostudio.org</hostname>
                         <port>9000</port>
                         <password>xxxxx</password>
                         <mount>/test.ogg</mount>
                         <reconnectdelay>2</reconnectdelay>
                         <reconnectattempts>5</reconnectattempts>
                         <encode>
                                 <samplerate>48000</samplerate>
                                 <channels>2</channels>
                                 <quality>0</quality>
                         </encode>
                 </instance>
         </stream>
</ices>

<p>Karl Heyes wrote:
> On 2002.12.02 21:46 smoerk wrote:
> 
>> I have problems with the stdinpcm module in ices2. The player fills 
>> its buffer and doen't play anything and fill the buffer again and this 
>> repeats (with winamp). when I download the stream with wget I can play 
>> it from hard disk... is this a common problem with ices2 or do only I 
>> experience this behaviour?
> 
> 
> I've heard of problems with winamp3 but I don't know what effect it has.
> 
> Last time I tried with stdinpcm it was just fine and I don't think there's
> been any changes to it.  Lets us know the winamp version and if you can
> try another player/plugin.  Also give us some idea on what your running
> number of instances, samplerates etc.
> 
> I presume the CPU isn't max'd out (vmstat 1 on unix - us column) and you
> have a recent version from CVS.

<p>--- >8 ----
List archives:  http://www.xiph.org/archives/
icecast project homepage: http://www.icecast.org/
To unsubscribe from this list, send a message to 'icecast-request at xiph.org'
containing only the word 'unsubscribe' in the body.  No subject is needed.
Unsubscribe messages sent to the list will be ignored/filtered.



More information about the Icecast mailing list