[icecast] IceS compiling problems

Brendan Cully brendan at icecast.org
Tue Apr 30 16:11:33 PDT 2002



On Wednesday, 01 May 2002 at 00:55, Cédric Mallet wrote:
> I have serious problems to compile IceS on a debian (woody), kernel 2.4.18.
> I have to say the configure script does not find anything...
> 
> - I installed libshout and libshout-dev downloaded drom the icecast site. I 
> have shout.h :
> 0:33 root at radiopi2 /usr/include/shout# ls
> shout.h
> 
> Yet configure gives me this :
> ~/sources/ices-0.2.2% ./configure --with-libshout=/usr/include
> checking for shout/shout.h... (cached) no
> configure: error: Could not find an installed shout library

First, make sure you remove config.cache
Second, don't bother with the --with-libshout option at all - ices
should find it automatically.
Third, you want --with-libshout=/usr

--with-x options that take an argument usually expect the same thing you
would use as --prefix when building it. This is standard autoconf
convention.

So when you say --with-libshout=/usr/include, the configure script
searches /usr/include/include/shout/shout.h and
/usr/include/lib/libshout.so

Fourth, you don't need libshout at all, ices comes with it.

> - Lame is not found neither. I have (lame and lame-dev 3.91 from deb 
> packages):
> lame in /usr/bin
> lame.h in /usr/include/lame
> lib files in /usr/lib :
> /usr/lib# ls -l libmp3lame* 
> -rw-r--r--    1 root     root       364104 fév  1 17:49 libmp3lame.a
> -rw-r--r--    1 root     root          668 fév  1 17:49 libmp3lame.la
> lrwxrwxrwx    1 root     root           19 mai  1 00:43 libmp3lame.so -> 
> libmp3lame.so.0.0.0
> lrwxrwxrwx    1 root     root           19 mai  1 00:43 libmp3lame.so.0 -> 
> libmp3lame.so.0.0.0
> -rw-r--r--    1 root     root       319696 fév  1 17:49 libmp3lame.so.0.0.0
> 
> And with that :
> ./configure --with-lame=/usr/bin --with-lame-includes=/usr/include/lame 
> --with-lame-libraries=/usr/lib

Same thing.
First, don't specify any argument.
Second, try only --with-lame
Third, if you really want to be precise, use --with-lame=/usr
Those other options (-includes, -libraries) are usually not needed
except in unusual installations.

> I think the problem is global and is not only about lame.
> I put the whole configuration output attached ; this is rather urgent, any 
> help is really welcome...

I think you just need a little more experience building from source.
Unfortunately there is no deb package for ices. I've been hoping to make
the linked in libraries loadable at runtime (dlopen'd) if I get the time
- this might make ices suitable for packaging with debian...

-b

--- >8 ----
List archives:  http://www.xiph.org/archives/
icecast project homepage: http://www.icecast.org/
To unsubscribe from this list, send a message to 'icecast-request at xiph.org'
containing only the word 'unsubscribe' in the body.  No subject is needed.
Unsubscribe messages sent to the list will be ignored/filtered.



More information about the Icecast mailing list