[icecast] admin 'rehash' broken in icecast 1.3.12?

Beau D. Simensen simensen at halogen.org
Sat Apr 20 17:00:02 PDT 2002



I tried admin rehash for the first time since upgrading to 1.3.12 today. The
rehash took at least 30 seconds [If not longer -- I didn't time it very
closely] and icecast slowly snuck up to 99% CPU usage. I tried issuing the
'alias' command just to try and get a response from the console and that
never responded. [I waited about two minutes]

I had the same experience both of my servers, one RedHat 7.2 and the other
FreeBSD 4.2-RELEASE. Restarting icecast seemed to fix the problem, but being
able to add aliases to the config and rehash was a really nice feature to
have. Did this break between 1.3.10 and 1.3.12? I had 1.3.11 somewhere in
there as well but I'm not sure I used rehash from the console while I was
running 1.3.11...

Thanks,

bds

<p>--- >8 ----
List archives:  http://www.xiph.org/archives/
icecast project homepage: http://www.icecast.org/
To unsubscribe from this list, send a message to 'icecast-request at xiph.org'
containing only the word 'unsubscribe' in the body.  No subject is needed.
Unsubscribe messages sent to the list will be ignored/filtered.



More information about the Icecast mailing list