[icecast] Unable to use playlist module in ices

Michael Smith msmith at labyrinth.net.au
Fri Nov 9 00:17:32 PST 2001



At 02:28 AM 11/9/01 -0500, you wrote:
>I have just downloaded from anoncvs at xiph.org the ogg, vorbis, icecast,
>and ices modules.  I compiled and installed all four modules without any
>errors.  I seem to have icecast working correctly (no errors in the
>logs), but I cannot get ices started.  I receive the following errors in
>the log file:
>
>[2001-11-09  07:04:54] EROR playlist-builtin/playlist_open_module No
>playlist type given, cannot initialise playlist module
>[2001-11-09  07:04:54] EROR input/input_loop Couldn't initialise input
>module "playlist"
>
>I use the following command:
>
>ices -c /usr/local/etc/ices-playlist.xml
>

Erm. I think I'll just give myself an F for error messages.
The correct error message here is 
"Incorrect usage. Usage is: ices configfile.xml". The actual error 
message you're getting is because it fails to open the config file,
then gets further, and finally gives up because there isn't a default
value for the playlist type. Anyway, no -c, just 
"ices /usr/local/etc/ices-playlist.xml"

I'll clean up the error messages here. You'll also need (you may have
it, but you didn't say...) the libshout module out of cvs. If it linked
anyway, you probably had an old libshout (for mp3 streaming) around,
it won't actually run.

Michael

--- >8 ----
List archives:  http://www.xiph.org/archives/
icecast project homepage: http://www.icecast.org/
To unsubscribe from this list, send a message to 'icecast-request at xiph.org'
containing only the word 'unsubscribe' in the body.  No subject is needed.
Unsubscribe messages sent to the list will be ignored/filtered.



More information about the Icecast mailing list