[icecast] multiple ices streams and misc other stuff?

Brendan Cully brendan at kublai.com
Sun Jun 10 20:18:32 PDT 2001



On Sunday, 10 June 2001 at 17:58, Kirk Reiser wrote:
> Hi Brendan:  The diff patched, configured and compiled just greate.  A
> bit of a false start because I chose a bitrate lame didn't like.  Once
> I figured that out however things went fine.  You might want to log
> the point lame dies on something which would help others know where to
> look for lame errors.

lame doesn't tell you exactly what's wrong, but I've made the error
message a bit more clear. But you'll have a lot of conflicts if you
try to cvs up with the patch applied, due to the new code for
"backward compatibility" with the oh-so-ancient 3.88beta of
lame. Aside from autoconf stuff, the only thing worth updating is
src/id3.c, which should now properly update the metadata for the first
track...

> On another note, I see ices still only accepts /tmp for the
> ices:Basedirectory tag.  I hope that's on someone's bug list.

ok, it is now.

> A very nice job.  I have three streams running 128, 56, and 24.  They
> all sound fine except for the 24 which is lames fault.  I have had it
> running long enough yet to know how it will do over time but that'll
> come. 'grin'

Thanks, it's good to have some feedback (and better to hear that it's
working!). For the 24kbit stream, did you make it mono (set
ices:Channels to 1)? that helps a lot I find...

-Brendan

--- >8 ----
List archives:  http://www.xiph.org/archives/
icecast project homepage: http://www.icecast.org/
To unsubscribe from this list, send a message to 'icecast-request at xiph.org'
containing only the word 'unsubscribe' in the body.  No subject is needed.
Unsubscribe messages sent to the list will be ignored/filtered.



More information about the Icecast mailing list