[icecast] stupid headers

William Goldsmith wildbill at kpig.com
Thu Apr 19 20:09:32 PDT 2001



With Winamp, you need to set the port to one number below the server port.
ie: if the server is on 8000, set Winamp to 7999. When used with a Shoutcast
server, Winamp uses the base port for metadata, & port+1 for the audio
stream & headers. You also need to have the Icecast server listen on both
ports (or run a second 'dummy' server on port-1) so that Winamp will at
least *think* that it's properly connected.

-bg

> When I run icecast 1.3.10 with shout 0.8.0 I get
>
> [/home/icecast/music/track01.mp3]
> [3:07] Size: 2997767 Bitrate: 128000 (38432 bytes/dot)
> [Error in read,
> exiting                                                        ]
> read: Broken pipe
>
> When I send a source stream using winamp, I get an invalid password
> error on winamp, and stupid headers on icecast.
>
> [19/Apr/2001:19:12:19] Kicking unknown 10 [64.170.116.180] [Stupid
> headers], connected for 0 seconds
>
> Anyone know why this happens?
>
> Sameer
>
> --- >8 ----
> List archives:  http://www.xiph.org/archives/
> icecast project homepage: http://www.icecast.org/
> To unsubscribe from this list, send a message to
'icecast-request at xiph.org'
> containing only the word 'unsubscribe' in the body.  No subject is needed.
> Unsubscribe messages sent to the list will be ignored/filtered.
>

--- >8 ----
List archives:  http://www.xiph.org/archives/
icecast project homepage: http://www.icecast.org/
To unsubscribe from this list, send a message to 'icecast-request at xiph.org'
containing only the word 'unsubscribe' in the body.  No subject is needed.
Unsubscribe messages sent to the list will be ignored/filtered.



More information about the Icecast mailing list