[flac-dev] Question: MSVS 2005/2008 support?

St├ęphane Damo stephane.damo at gmail.com
Wed May 2 14:25:06 UTC 2018


I don't like the decision to remove the old VS project files, in my opinion
it's better to keep them, marked "not updated anymore".
I personnally use VS2013, and the reason I don't want to upgrade is the
fact that VS2017 requires online registration to work. I'm pretty sure some
users also have valid reasons to keep their old VS.

On 2 May 2018 at 14:37, lvqcl <lvqcl.mail at gmail.com> wrote:

> By default, FLAC requires ogg library. Support of old versions of
> Visual Studio was removed from libogg code about 2 years ago:
> https://git.xiph.org/?p=ogg.git;a=commit;h=18c401c6bc8814d06f3ae53ebf5d43
> 99f90871cc
>
> libogg 1.3.3 (released 2017-11-07) cannot be built with MSVS 2005/2008
> anymore.
>
> Are there any developers that want to use libFLAC in their programs
> and still use Visual Studio 2005 or 2008 ?
>
> On the other hand, libvorbis 1.3.6 (released 2018-03-16) also needs
> libogg and still has project files for MSVS 2005/2008 as well as 2010.
> _______________________________________________
> flac-dev mailing list
> flac-dev at xiph.org
> http://lists.xiph.org/mailman/listinfo/flac-dev
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.xiph.org/pipermail/flac-dev/attachments/20180502/6e1f65ac/attachment.html>


More information about the flac-dev mailing list