[flac-dev] [PATCH 4] for test_libFLAC/bitwriter.c

Erik de Castro Lopo mle+la at mega-nerd.com
Thu Dec 31 00:18:43 PST 2015

lvqcl wrote:

> 1) The definition of FLAC__BitWriter was updated with the
> current text from /libFLAC/bitwriter.c (the text in comments was changed).
> And the definition of TOTAL_BITS was made closer to the code from /libFLAC/bitwriter.c.
> 2) The values for 'words' and 'bits' values now calculated, not just some
> magic constants.
> 3) Added FLAC__U64L() for 64-bit constants. It seems that it isn't
> necessary (the values of these constants are less than 2^32), but
> IMHO the code looks better with FLAC__U64L.

Applied. Thanks.

Erik de Castro Lopo

More information about the flac-dev mailing list