[flac-dev] [PATCH] for cpu.h

lvqcl lvqcl.mail at gmail.com
Tue Sep 23 10:22:32 PDT 2014


Currently the structure of FLAC__cpu_info() is:

void FLAC__cpu_info(FLAC__CPUInfo *info)
{
     ... // init

     if(info->ia32.cpuid) {
         ... // very long code
         ...
         ...
         ...
         ...
         ...
         ...
         ...
     }
}


This patch changes it to:


void FLAC__cpu_info(FLAC__CPUInfo *info)
{
     ... // init

     if(info->ia32.cpuid == false)
         return;

     ... // very long code
     ...
     ...
     ...
     ...
     ...
     ...
     ...
}


IMHO it's more readable this way.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: cpu_cpuid.zip
Type: application/zip
Size: 2555 bytes
Desc: not available
Url : http://lists.xiph.org/pipermail/flac-dev/attachments/20140923/05505d55/attachment.zip 


More information about the flac-dev mailing list